]> code.ossystems Code Review - openembedded-core.git/commitdiff
libpcre: Fix BUILD_CFLAGS for out of tree support
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 23 Mar 2013 12:55:19 +0000 (12:55 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 23 Mar 2013 12:57:42 +0000 (12:57 +0000)
The BUILD_CFLAGS were broken since /include no longer exists in this package. We
do need to include ${B} in the include path for pcre.h though.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/libpcre/libpcre_8.32.bb

index 04b76f320f20d0a00306eeafa0224c7e246d1a1d..4d17741625e22eaeffb4c492b08fa05403cb09cc 100644 (file)
@@ -36,7 +36,7 @@ EXTRA_OECONF = "\
 
 # Set LINK_SIZE in BUILD_CFLAGS given that the autotools bbclass use it to
 # set CFLAGS_FOR_BUILD, required for the libpcre build.
-BUILD_CFLAGS =+ "-DLINK_SIZE=2 -I${S}/include"
+BUILD_CFLAGS =+ "-DLINK_SIZE=2 -I${B}"
 CFLAGS += "-D_REENTRANT"
 CXXFLAGS_append_powerpc = " -lstdc++"