]> code.ossystems Code Review - openembedded-core.git/commitdiff
net-tools: Fix rerunning of do_patch task
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 21 Jan 2015 17:33:55 +0000 (17:33 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 11 Feb 2015 17:39:51 +0000 (17:39 +0000)
Rerunning the do_patch task currently fails. The code is nearly correct
but needs to remove the quilt ".pc" directory and move the secondary
one into place in order to rerun, not move it into the .pc directory
as the code currently does.

[YOCTO #7128]

(From OE-Core rev: 2a775ebbb175dd70fc7228607c306d4ccb9e4ba4)

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-extended/net-tools/net-tools_1.60-25.bb

index 02826a09c94edd672efac9254341a0ca2bb90b86..0e4ee754a4ae54090408a1d42e38c9a7f9e44e9e 100644 (file)
@@ -34,6 +34,7 @@ nettools_do_patch() {
        cd ${S}
        quilt pop -a || true
        if [ -d ${S}/.pc-nettools ]; then
+               rm -rf ${S}/.pc
                mv ${S}/.pc-nettools ${S}/.pc
                QUILT_PATCHES=${S}/debian/patches quilt pop -a
                rm -rf ${S}/.pc ${S}/debian