]> code.ossystems Code Review - openembedded-core.git/commitdiff
scripts: Add meta-darwin build to the autobuilder
authorRichard Purdie <richard@openedhand.com>
Thu, 1 May 2008 09:49:43 +0000 (09:49 +0000)
committerRichard Purdie <richard@openedhand.com>
Thu, 1 May 2008 09:49:43 +0000 (09:49 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4380 311d38ba-8fff-0310-9ca6-ca027cbcb966

scripts/poky-autobuild
scripts/pokyABConfig.py

index 48c7df84031bf5eea4e2831e8283c07de9cc680f..05857905063aa31053075855041279cc238bdcbd 100755 (executable)
@@ -28,6 +28,8 @@ elif [ "$CURRDIR" = "/srv/poky/autobuild/toolchain-shihtzu/build" ]; then
     ABTARGET="toolchain"
 elif [ "$CURRDIR" = "/srv/poky/autobuild/incremental-shihtzu/build" ]; then
     ABTARGET="incremental"
+elif [ "$CURRDIR" = "/srv/poky/autobuild/full-darwin-shihtzu/build" ]; then
+    ABTARGET="darwin"
 fi
 
 if [ "xpreamble" = "x$1" ]; then
@@ -61,6 +63,24 @@ if [ ! -e "$CONFFILE" ]; then
     echo 'BB_NUMBER_THREADS = "6"' >> "$CONFFILE"
     echo 'PARALLEL_MAKE = "-j 6"' >> "$CONFFILE"
     echo 'DL_DIR = "/srv/poky/sources"' >> "$CONFFILE"
+    if [ "$ABTARGET" = "darwin" ]; then
+       if [ ! -d "$CURRDIR/meta-darwin" ]; then
+           svn co http://svn.o-hand.com/repos/poky/branches/experimental/meta-darwin $CURRDIR/meta-darwin
+       else
+           cd $CURRDIR/meta-darwin
+           svn up
+       fi
+        echo 'PACKAGE_CLASSES += "package_tar"' > "$CONFFILE"
+       echo "BBFILES += \"$CURRDIR/meta-darwin/packages/*/*.bb\"" > "$CONFFILE"
+        echo 'POKYMODE = "darwin"' > "$CONFFILE"
+        echo 'DARWINFILES = "file:///srv/poky/sources/"' > "$CONFFILE"
+        echo 'INHERIT_INSANE = ""' > "$CONFFILE"
+        echo 'FILESPATH_append = ":$CURRDIR/meta-darwin/files"' > "$CONFFILE"
+    fi
+fi
+
+if [ "$ABTARGET" = "darwin" ]; then
+    BBPATH=$CURRDIR/meta-darwin:$BBPATH
 fi
 
 bitbake $@
index 1b5aec06534a34b7d5449790f97b769aca3c9b6b..00898d49df646b21a3e29d0898592a8355a65d62 100644 (file)
@@ -101,6 +101,16 @@ runImage(f6, 'qemux86', 'meta-toolchain-sdk')
 runImage(f6, 'qemuarm', 'world -c checkuriall')
 runComplete(f6)
 
+from buildbot.process import step, factory
+f7 = factory.BuildFactory()
+f7.addStep(step.SVN, svnurl="http://svn.o-hand.com/repos/poky/trunk", mode="copy", timeout=10000)
+runPreamble(f7)
+defaultenv['DISTRO'] = 'poky'
+defaultenv['POKYLIBC'] = 'dummy'
+runImage(f7, 'ipodtouch', 'meta-clutter')
+defaultenv['POKYLIBC'] = 'glibc'
+runComplete(f7)
+
 #from buildbot.process import step, factory
 #f7 = factory.BuildFactory()
 #f7.addStep(step.SVN, svnurl="http://svn.o-hand.com/repos/poky/trunk", timeout=10000)
@@ -134,11 +144,17 @@ b6 = {'name': "poky-toolchain-shihtzu",
       'factory': f6
       }
 
+b7 = {'name': "poky-full-darwin-shihtzu",
+      'slavename': "shihtzu-autobuild",
+      'builddir': "full-darwin-shihtzu",
+      'factory': f7
+      }
+
 #b7 = {'name': "poky-incremental-world-shihtzu",
 #      'slavename': "shihtzu-autobuild",
 #      'builddir': "incremental-world-shihtzu",
 #      'factory': f7
 #      }
 
-poky_builders = [b3, b4, b5, b6]
+poky_builders = [b3, b4, b5, b6, b7]