]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3: fix build for shared object
authorRobert Yang <liezhi.yang@windriver.com>
Thu, 28 May 2015 09:22:24 +0000 (02:22 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 28 Jun 2015 08:41:57 +0000 (09:41 +0100)
Fixed when build on armv7a_vfp_neon:
Python-3.3.3/Modules/_struct.o: relocation R_ARM_MOVW_ABS_NC against `a local symbol' can not be used when making a shared object; recompile with -fPIC

All the archs should use -fPIC when build shared object for linux.

(From OE-Core rev: 60c1f76f65060cbea458b06f9719a2536f50474e)

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python3_3.3.3.bb

index 6147408937bb0d0efdde96c4df5d8f4a1f2e1042..897aba91582948d06bcea4ef7f7431d52432dcbd 100644 (file)
@@ -71,6 +71,7 @@ EXTRA_OECONF += "CROSSPYTHONPATH=${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}
 export CROSS_COMPILE = "${TARGET_PREFIX}"
 export _PYTHON_PROJECT_BASE = "${B}"
 export _PYTHON_PROJECT_SRC = "${S}"
+export CCSHARED = "-fPIC"
 
 # No ctypes option for python 3
 PYTHONLSBOPTS = ""