]> code.ossystems Code Review - openembedded-core.git/commitdiff
vim: _FORTIFY_SOURCE=2 be gone
authorJoe Slater <joe.slater@windriver.com>
Sat, 6 Jun 2020 17:17:01 +0000 (10:17 -0700)
committerSteve Sakoman <steve@sakoman.com>
Tue, 16 Jun 2020 20:14:02 +0000 (10:14 -1000)
vim will abort in many places with this setting.  Replace
it with the benign _FORTIFY_SOURCE=1.

Signed-off-by: Joe Slater <joe.slater@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 18129cbaeddb3278efe9963718556e3765f06c1e)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-support/vim/vim_8.2.bb

index 60946a181f4296004705d52452bda04a0994ce6f..709b6ddb55668ae3afe543aae5496fd56d1fb1ec 100644 (file)
@@ -8,3 +8,8 @@ BBCLASSEXTEND = "native"
 ALTERNATIVE_${PN}_append = " xxd"
 ALTERNATIVE_TARGET[xxd] = "${bindir}/xxd"
 ALTERNATIVE_LINK_NAME[xxd] = "${bindir}/xxd"
+
+# We override the default in security_flags.inc because vim (not vim-tiny!) will abort
+# in many places for _FORTIFY_SOURCE=2.  Security flags become part of CC.
+#
+lcl_maybe_fortify = "${@oe.utils.conditional('DEBUG_BUILD','1','','-D_FORTIFY_SOURCE=1',d)}"