]> code.ossystems Code Review - openembedded-core.git/commitdiff
runtime: Update test cases numbers for runtime tests
authorJose Perez Carranza <jose.perez.carranza@linux.intel.com>
Thu, 24 Nov 2016 17:22:32 +0000 (11:22 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 30 Nov 2016 15:47:14 +0000 (15:47 +0000)
Update test case numbers on runtime tests to do match
with templates defined on Testopia for 2.3 release

Signed-off-by: Jose Perez Carranza <jose.perez.carranza@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/lib/oeqa/runtime/buildgalculator.py
meta/lib/oeqa/runtime/kernelmodule.py
meta/lib/oeqa/runtime/logrotate.py
meta/lib/oeqa/runtime/pam.py

index 28ba29e5c231177d08d77c560f3e5c7df65f7905..220101d55c753d5670f93f4848ef57652192d363 100644 (file)
@@ -7,6 +7,7 @@ def setUpModule():
         skipModule("Image doesn't have tools-sdk in IMAGE_FEATURES")
 
 class GalculatorTest(oeRuntimeTest):
+    @testcase(1526)
     @skipUnlessPassed("test_ssh")
     def test_galculator(self):
         try:
index 38ca184540cfe26a878d56b0b265467ee4c8274b..2ac1bc93d481a1aba112040010b0141def3b6bc4 100644 (file)
@@ -14,7 +14,7 @@ class KernelModuleTest(oeRuntimeTest):
         self.target.copy_to(os.path.join(oeRuntimeTest.tc.filesdir, "hellomod.c"), "/tmp/hellomod.c")
         self.target.copy_to(os.path.join(oeRuntimeTest.tc.filesdir, "hellomod_makefile"), "/tmp/Makefile")
 
-    @testcase('316')
+    @testcase('1541')
     @skipUnlessPassed('test_ssh')
     @skipUnlessPassed('test_gcc_compile')
     def test_kernel_module(self):
index de300bf55f6139a82fd8e74bf327d49dca4d5f02..cf88c54dfa45578029ab3f31400cc65b554d3f5a 100644 (file)
@@ -12,6 +12,7 @@ def setUpModule():
 
 class LogrotateTest(oeRuntimeTest):
 
+    @testcase(1544)
     @skipUnlessPassed("test_ssh")
     def test_1_logrotate_setup(self):
         (status, output) = self.target.run('mkdir $HOME/logrotate_dir')
@@ -19,7 +20,7 @@ class LogrotateTest(oeRuntimeTest):
         (status, output) = self.target.run("sed -i \"s#wtmp {#wtmp {\\n    olddir $HOME/logrotate_dir#\" /etc/logrotate.conf")
         self.assertEqual(status, 0, msg = "Could not write to logrotate.conf file. Status and output: %s and %s)" % (status, output))
 
-    @testcase(289)
+    @testcase(1542)
     @skipUnlessPassed("test_1_logrotate_setup")
     def test_2_logrotate(self):
         (status, output) = self.target.run('logrotate -f /etc/logrotate.conf')
index c8205c9abcc34b765b362e6db77dfc67e03a1328..b7f2dfa49b9bcf255be1c8ab5576bfbe968e8c7e 100644 (file)
@@ -12,7 +12,7 @@ def setUpModule():
 
 class PamBasicTest(oeRuntimeTest):
 
-    @testcase(287)
+    @testcase(1543)
     @skipUnlessPassed('test_ssh')
     def test_pam(self):
         (status, output) = self.target.run('login --help')