]> code.ossystems Code Review - openembedded-core.git/commitdiff
New package: ptest-runner
authorBjörn Stenberg <bjst@enea.com>
Wed, 19 Dec 2012 16:18:28 +0000 (17:18 +0100)
committerSaul Wold <sgw@linux.intel.com>
Tue, 25 Dec 2012 22:00:20 +0000 (14:00 -0800)
This package contains a simple shell script which searches for all installed
ptests on the rootfs and runs each test in sequence.

Signed-off-by: Björn Stenberg <bjst@enea.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-support/ptest-runner/files/ptest-runner [new file with mode: 0644]
meta/recipes-support/ptest-runner/ptest-runner_1.0.bb [new file with mode: 0644]

diff --git a/meta/recipes-support/ptest-runner/files/ptest-runner b/meta/recipes-support/ptest-runner/files/ptest-runner
new file mode 100644 (file)
index 0000000..4f3c7ce
--- /dev/null
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+echo "START: $0"
+cd /usr/lib
+for x in *
+do
+    if [ -x "/usr/lib/$x/ptest/run-ptest" ]; then
+       date "+%Y-%m-%dT%H:%M"
+        echo "BEGIN: $x"
+        cd /usr/lib/$x/ptest
+        ./run-ptest
+        echo "END: $x"
+       date "+%Y-%m-%dT%H:%M"
+    fi
+done
+echo "STOP: $0"
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_1.0.bb b/meta/recipes-support/ptest-runner/ptest-runner_1.0.bb
new file mode 100644 (file)
index 0000000..6b866d4
--- /dev/null
@@ -0,0 +1,17 @@
+SRC_URI += "file://ptest-runner"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+                    file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+INHIBIT_DEFAULT_DEPS = "1"
+
+do_install () {
+    mkdir -p ${D}${bindir}
+    install -m 0755 ${WORKDIR}/ptest-runner ${D}${bindir}
+}
+
+do_patch[noexec] = "1"
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+do_build[noexec] = "1"