]> code.ossystems Code Review - openembedded-core.git/commitdiff
Allow psplash to be disabled via kernel cmd line
authorMatthew Allum <mallum@openedhand.com>
Thu, 14 Dec 2006 11:49:37 +0000 (11:49 +0000)
committerMatthew Allum <mallum@openedhand.com>
Thu, 14 Dec 2006 11:49:37 +0000 (11:49 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1033 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/psplash/files/psplash-init
meta/packages/psplash/psplash_svn.bb

index b736cc637516361fc25f18aa8845b00714bac1d5..a966638074d855c66878ae2755c0e65e266ed4f4 100755 (executable)
@@ -1,5 +1,14 @@
 #!/bin/sh 
 
+for x in $(cat /proc/cmdline); do
+        case $x in
+        psplash=false)
+               echo "Boot splashscreen disabled" 
+               exit 0;
+                ;;
+        esac
+done
+
 export TMPDIR=/mnt/.psplash
 mount tmpfs -t tmpfs $TMPDIR -o,size=40k
 
index 2c21c99d7d5d587ecbe9a12602dfa51ab5dfcc8c..5ac42f9ec740b385f03e9610083e96c71344e072 100644 (file)
@@ -2,6 +2,7 @@ DESCRIPTION = "Userspace framebuffer boot logo based on usplash."
 SECTION = "base"
 LICENSE = "GPL"
 PV = "0.0+svn${SRCDATE}"
+PR = "r1"
 
 SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
            file://psplash-init"