]> code.ossystems Code Review - openembedded-core.git/commitdiff
glibc: don't override TUNE_CCARGS for MIPS
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Wed, 1 Jul 2015 14:02:22 +0000 (17:02 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 31 Jul 2015 14:15:13 +0000 (15:15 +0100)
Overriding TUNE_CCARGS this way breaks MULTILIB setup for MIPS. This
override disables multilib handling of tunes for TUNE_CCARGS, thus
enforcing glibc's TUNE_CCARGS to the TUNE_CCARGS of main DEFAULTTUNE.

Glibc perfectly build without this override for both simple and multilib
cases.

Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/glibc/glibc_2.21.bb

index 30f19376e8d26725df8c5812b12468d9217230a3..55424bfaacee59469585d3490feafbd9acc7144f 100644 (file)
@@ -95,16 +95,6 @@ do_patch_append() {
     bb.build.exec_func('do_fix_readlib_c', d)
 }
 
-# for mips glibc now builds syscall tables for all abi's
-# so we make sure that we choose right march option which is
-# compatible with o32,n32 and n64 abi's
-# e.g. -march=mips32 is not compatible with n32 and n64 therefore
-# we filter it out in such case -march=from-abi which will be
-# mips1 when using o32 and mips3 when using n32/n64
-
-TUNE_CCARGS_mips := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
-TUNE_CCARGS_mipsel := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
-
 do_fix_readlib_c () {
        sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
 }