]> code.ossystems Code Review - openembedded-core.git/commitdiff
nss-myhostname: skip it when systemd
authorRobert Yang <liezhi.yang@windriver.com>
Thu, 9 Oct 2014 09:39:09 +0000 (02:39 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 10 Oct 2014 09:39:13 +0000 (10:39 +0100)
Fixed error when systemd is in DISTRO_FEATURES:
ERROR: The recipe systemd is trying to install files into a sharedarea when those files already exist. Those files and their manifestlocation are:
   /path/to/sysroots/qemux86/usr/lib/libnss_myhostname.so.2
 Matched in manifest-qemux86-nss-myhostname.populate_sysroot
Please verify which recipe should provide theabove files.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-support/nss-myhostname/nss-myhostname_0.3.bb

index 12376025534d3f2ca3add1e8407ed606fe6c18c8..bbce9e9af00d64e377479b4e6eb34b78f3116ba0 100644 (file)
@@ -11,7 +11,10 @@ SRC_URI = "http://0pointer.de/lennart/projects/nss-myhostname/nss-myhostname-${P
 SRC_URI[md5sum] = "d4ab9ac36c053ab8fb836db1cbd4a48f"
 SRC_URI[sha256sum] = "2ba744ea8d578d1c57c85884e94a3042ee17843a5294434d3a7f6c4d67e7caf2"
 
-inherit autotools
+inherit autotools distro_features_check
+
+# The systemd has its own copy of nss-myhostname
+CONFLICT_DISTRO_FEATURES = "systemd"
 
 pkg_postinst_${PN} () {
        sed -e '/^hosts:/s/\s*\<myhostname\>//' \