]> code.ossystems Code Review - openembedded-core.git/commitdiff
libatomics-ops: patch source code for x32
authorNitin A Kamble <nitin.a.kamble@intel.com>
Fri, 2 Dec 2011 20:20:09 +0000 (12:20 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 5 Dec 2011 22:46:16 +0000 (22:46 +0000)
This Fixes bug: [YOCTO #1418]

Remove the `q' suffix on x86-64 atomic instructions.

We don't need the `q' suffix on x86_64 atomic instructions for AO_t,
which is defined as "unsigned long".  "unsigned long" is 32bit for x32
and 64bit for x86-64. The register operand in x86-64 atomic instructions
is sufficient to properly determine the register size.

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Signed-off-by: H.J. Lu <hjl.tools@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-multimedia/pulseaudio/libatomics-ops/libatomics-ops_fix_for_x32.patch [new file with mode: 0644]
meta/recipes-multimedia/pulseaudio/libatomics-ops_1.2.bb

diff --git a/meta/recipes-multimedia/pulseaudio/libatomics-ops/libatomics-ops_fix_for_x32.patch b/meta/recipes-multimedia/pulseaudio/libatomics-ops/libatomics-ops_fix_for_x32.patch
new file mode 100644 (file)
index 0000000..1768606
--- /dev/null
@@ -0,0 +1,41 @@
+Upstream-Status: Pending
+
+Remove the `q' suffix on x86-64 atomic instructions.
+
+We don't need the `q' suffix on x86_64 atomic instructions for AO_t,
+which is defined as "unsigned long".  "unsigned long" is 32bit for x32
+and 64bit for x86-64. The register operand in x86-64 atomic instructions
+is sufficient to properly determine the register size.
+
+Received this patch from H.J. Lu <hjl.tools@gmail.com>
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com> 2011/12/02
+
+--- libatomic_ops-1.2/src/atomic_ops/sysdeps/gcc/x86_64.h.x32  2005-09-28 17:16:38.000000000 -0700
++++ libatomic_ops-1.2/src/atomic_ops/sysdeps/gcc/x86_64.h      2011-12-02 09:29:54.265251875 -0800
+@@ -60,7 +60,7 @@ AO_fetch_and_add_full (volatile AO_t *p,
+ {
+   AO_t result;
+-  __asm__ __volatile__ ("lock; xaddq %0, %1" :
++  __asm__ __volatile__ ("lock; xadd %0, %1" :
+                       "=r" (result), "=m" (*p) : "0" (incr), "m" (*p)
+                       : "memory");
+   return result;
+@@ -111,7 +111,7 @@ AO_int_fetch_and_add_full (volatile unsi
+ AO_INLINE void
+ AO_or_full (volatile AO_t *p, AO_t incr)
+ {
+-  __asm__ __volatile__ ("lock; orq %1, %0" :
++  __asm__ __volatile__ ("lock; or %1, %0" :
+                       "=m" (*p) : "r" (incr), "m" (*p) : "memory");
+ }
+@@ -136,7 +136,7 @@ AO_compare_and_swap_full(volatile AO_t *
+                            AO_t old, AO_t new_val) 
+ {
+   char result;
+-  __asm__ __volatile__("lock; cmpxchgq %3, %0; setz %1"
++  __asm__ __volatile__("lock; cmpxchg %3, %0; setz %1"
+                      : "=m"(*addr), "=q"(result)
+                      : "m"(*addr), "r" (new_val), "a"(old) : "memory");
+   return (int) result;
index c84917a7b312ce3eb7dab70a5833996109910148..184c167fc013817c464e36616f45a084693c7195 100644 (file)
@@ -6,12 +6,13 @@ LICENSE = "GPLv2 & MIT"
 LIC_FILES_CHKSUM = "file://doc/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
                     file://doc/LICENSING.txt;md5=607073e04548eac7d1f763e480477bab \
                   "
-PR = "r7"
+PR = "r8"
 
 SRC_URI = "http://www.hpl.hp.com/research/linux/atomic_ops/download/libatomic_ops-${PV}.tar.gz \
            file://fedora/libatomic_ops-1.2-ppclwzfix.patch \
            file://gentoo/libatomic_ops-1.2-mips.patch \
-           file://doublefix.patch"
+           file://doublefix.patch \
+           file://libatomics-ops_fix_for_x32.patch"
 
 SRC_URI[md5sum] = "1b65e48271c81e3fa2d7a9a69bab7504"
 SRC_URI[sha256sum] = "a3d8768aa8fd2f6ae79be2d756b3a6b48816b3889ae906be3d5ffb2de5a5c781"