]> code.ossystems Code Review - openembedded-core.git/commitdiff
e2fsprogs: Fix configure quoting to work with recent autoconf/automake
authorRichard Purdie <rpurdie@linux.intel.com>
Mon, 1 Feb 2010 11:48:50 +0000 (11:48 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 1 Feb 2010 11:48:50 +0000 (11:48 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/e2fsprogs/e2fsprogs-1.41.5/quotefix.patch [new file with mode: 0644]
meta/packages/e2fsprogs/e2fsprogs_1.41.5.bb

diff --git a/meta/packages/e2fsprogs/e2fsprogs-1.41.5/quotefix.patch b/meta/packages/e2fsprogs/e2fsprogs-1.41.5/quotefix.patch
new file mode 100644 (file)
index 0000000..528e319
--- /dev/null
@@ -0,0 +1,43 @@
+These macros are underquoted and break with recent autoconf+automake
+combinations.
+
+RP 1/2/10
+
+Index: e2fsprogs-1.41.5/configure.in
+===================================================================
+--- e2fsprogs-1.41.5.orig/configure.in 2010-02-01 11:40:10.547790252 +0000
++++ e2fsprogs-1.41.5/configure.in      2010-02-01 11:44:51.577876485 +0000
+@@ -397,11 +397,11 @@
+               AC_MSG_ERROR([pkg-config not installed; please install it.])
+       fi
+-      AC_CHECK_LIB(blkid, blkid_get_cache,
++      [AC_CHECK_LIB(blkid, blkid_get_cache,
+               [LIBBLKID=`$PKG_CONFIG --libs blkid`;
+                STATIC_LIBBLKID=`$PKG_CONFIG --static --libs blkid`],
+               [AC_MSG_ERROR([external blkid library not found])],
+-              [$LIBBLKID])
++              [$LIBBLKID])]
+       BLKID_CMT=#
+       AC_MSG_RESULT([Disabling private blkid library])
+ else
+@@ -786,15 +786,15 @@
+ dnl
+ SEM_INIT_LIB=''
+ AC_CHECK_FUNC(sem_init, ,
+-  AC_CHECK_LIB(pthread, sem_init,
++  [AC_CHECK_LIB(pthread, sem_init,
+       AC_DEFINE(HAVE_SEM_INIT)
+       SEM_INIT_LIB=-lpthread,
+-  AC_CHECK_LIB(rt, sem_init,
++  [AC_CHECK_LIB(rt, sem_init,
+       AC_DEFINE(HAVE_SEM_INIT)
+       SEM_INIT_LIB=-lrt,
+-  AC_CHECK_LIB(posix4, sem_init,
++  [AC_CHECK_LIB(posix4, sem_init,
+       AC_DEFINE(HAVE_SEM_INIT)
+-      SEM_INIT_LIB=-lposix4))))dnl
++      SEM_INIT_LIB=-lposix4)])])])dnl
+ AC_SUBST(SEM_INIT_LIB)
+ dnl
+ dnl Check for unified diff
index 66d283b268d69e965b1039f60912236c6bfd1a6f..82280a6bf4ce4c08ca9a938498eb8735765c10ff 100644 (file)
@@ -1,8 +1,9 @@
 require e2fsprogs.inc
 
-PR = "r15"
+PR = "r16"
 
-SRC_URI += "file://no-hardlinks.patch;patch=1"
+SRC_URI += "file://no-hardlinks.patch;patch=1 \
+            file://quotefix.patch;patch=1"
 
 PARALLEL_MAKE = ""