]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-2.7.2: fix build issues when additional modules are linked against host or...
authorMartin Jansa <Martin.Jansa@gmail.com>
Sat, 29 Oct 2011 20:10:08 +0000 (22:10 +0200)
committerMartin Jansa <Martin.Jansa@gmail.com>
Mon, 31 Oct 2011 17:01:55 +0000 (18:01 +0100)
* -L. is needed to find right libpython
* -L${STAGING_LIBDIR} is needed ie for python-zlib to find right zlib

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
meta/recipes-devtools/python/python_2.7.2.bb

index af14adbbb3d1005beaa69525487c32c730774728..45d8350376baa3e2410c4a4bb64e505a8e4c42ce 100644 (file)
@@ -51,6 +51,7 @@ do_compile() {
        install -m 0644 Makefile Makefile.orig
        sed -i -e 's,${includedir},${STAGING_INCDIR},' Makefile
        sed -i -e 's,${libdir},${STAGING_LIBDIR},' Makefile
+       sed -i -e 's,LDFLAGS=,LDFLAGS=-L. -L${STAGING_LIBDIR},' Makefile
        install -m 0644 Makefile ${STAGING_LIBDIR}/python${PYTHON_MAJMIN}/config/
        # save copy of it now, because if we do it in do_install and 
        # then call do_install twice we get Makefile.orig == Makefile.sysroot