]> code.ossystems Code Review - openembedded-core.git/commitdiff
sed: use ALTERNATIVE_LINK
authorKevin Tian <kevin.tian@intel.com>
Mon, 18 Oct 2010 09:38:32 +0000 (17:38 +0800)
committerSaul Wold <Saul.Wold@intel.com>
Mon, 18 Oct 2010 17:10:36 +0000 (10:10 -0700)
update-alternatives.bbclass assumes /usr/bin/sed if ALTERNATIVE_LINK is not
specified, however sed has changed its default installation directory to
/bin/sed. This causes below errors at the first boot of lsb image:

update-alternatives: Error: cannot register alternative sed to /usr/bin/sed
since it is already registered to /bin/sed

This fixes [BUGID #478]

Signed-off-by: Kevin Tian <kevin.tian@intel.com>
meta/recipes-extended/sed/sed_4.1.2.bb
meta/recipes-extended/sed/sed_4.2.1.bb

index e243f3e25f151777a365682298c233a135cf04bd..80d4b034f9729f3bd05145bdcc5ada068fe9a74d 100644 (file)
@@ -4,7 +4,7 @@ LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
                     file://sed/sed.h;beginline=1;endline=17;md5=e00ffd1837f298439a214fd197f6a407"
 SECTION = "console/utils"
-PR = "r4"
+PR = "r5"
 
 DEPENDS = "gettext"
 
@@ -21,6 +21,7 @@ do_install () {
 
 ALTERNATIVE_NAME = "sed"
 ALTERNATIVE_PATH = "sed.${PN}"
+ALTERNATIVE_LINK = "${base_bindir}/sed"
 ALTERNATIVE_PRIORITY = "100"
 
 BBCLASSEXTEND = "native"
index 5147b0d12e7d0dc0d0302935f8dfbaefdfc72424..734b1e0fcd84f729b22029b532241cdb1a8a4618 100644 (file)
@@ -4,7 +4,7 @@ LICENSE = "GPLv3+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
                     file://sed/sed.h;beginline=1;endline=17;md5=767ab3a06d7584f6fd0469abaec4412f"
 SECTION = "console/utils"
-PR = "r0"
+PR = "r1"
 
 DEPENDS = "gettext"
 
@@ -20,6 +20,7 @@ do_install () {
 
 ALTERNATIVE_NAME = "sed"
 ALTERNATIVE_PATH = "sed.${PN}"
+ALTERNATIVE_LINK = "${base_bindir}/sed"
 ALTERNATIVE_PRIORITY = "100"
 
 BBCLASSEXTEND = "native"