]> code.ossystems Code Review - openembedded-core.git/commitdiff
tslib: Fix tslib.sh for spitz
authorRichard Purdie <richard@openedhand.com>
Tue, 28 Nov 2006 13:03:23 +0000 (13:03 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 28 Nov 2006 13:03:23 +0000 (13:03 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@967 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/tslib/tslib/jornada7xx/ts.conf
meta/packages/tslib/tslib/jornada7xx/tslib.sh
meta/packages/tslib/tslib/spitz/tslib.sh
meta/packages/tslib/tslib_1.0.bb

index 20729b61540ef0464f938b267b7e1ea04e881c0c..09309719f29398b442e054f58e988bec5aa20792 100644 (file)
@@ -1,4 +1,4 @@
-module_raw h3600
+module_raw input
 module pthres pmin=1
 module variance delta=30
 module dejitter delta=100
index 1b5db781c1e6aa7813f7c94d451b847bef550e81..040f4de3d5e5c6a939b6601942bff9af199b5e2c 100644 (file)
@@ -1,5 +1,5 @@
 #!/bin/sh
 
-TSLIB_TSDEVICE=/dev/input/ts0
+TSLIB_TSDEVICE=/dev/input/event1
 
 export TSLIB_TSDEVICE
index 0c8b1a12b9b59304bbb848214222de2db9faf29b..0ff219b31fd650e076ab3ac6ce7a94bf37bb2d4a 100644 (file)
@@ -1,16 +1,13 @@
 #!/bin/sh
 
+TSLIB_TSDEVICE=/dev/input/touchscreen0
+TSLIB_CONFFILE=/etc/ts.conf
+
 case `uname -r` in
 2.4*)
        TSLIB_TSDEVICE=/dev/ts
-       TSLIB_TSEVENTTYPE=CORGI
        TSLIB_CONFFILE=/usr/share/tslib/ts.conf-corgi-2.4
        ;;
-*)
-       TSLIB_TSDEVICE=/dev/input/touchscreen0
-       TSLIB_TSEVENTTYPE=INPUT
-       TSLIB_CONFFILE=/usr/share/tslib/ts-2.6.conf
-       ;;
 esac
 
-export TSLIB_TSDEVICE TSLIB_TSEVENTTYPE TSLIB_CONFFILE
+export TSLIB_TSDEVICE TSLIB_CONFFILE
index 5e5f61cb352c6703ccd0147c84a86881b6ee8261..3a5b8bab4db2fa6636230a469308f356eacba011 100644 (file)
@@ -4,7 +4,7 @@ AUTHOR = "Russell King w/ plugins by Chris Larson et. al."
 SECTION = "base"
 LICENSE = "LGPL"
 
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "http://download.berlios.de/tslib/tslib-1.0.tar.bz2 \
            file://ts.conf \