]> code.ossystems Code Review - openembedded-core.git/commitdiff
recipes-graphics: replace virtclass-native(sdk) with class-native(sdk)
authorRobert Yang <liezhi.yang@windriver.com>
Sat, 27 Oct 2012 08:48:17 +0000 (16:48 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 2 Nov 2012 16:15:30 +0000 (16:15 +0000)
The overrides virtclass-native and virtclass-nativesdk are deprecated,
which should be replaced by class-native and class-nativesdk.

[YOCTO #3297]

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-graphics/freetype/freetype_2.4.10.bb
meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
meta/recipes-graphics/pango/pango.inc
meta/recipes-graphics/xcb/xcb-proto.inc
meta/recipes-graphics/xorg-app/mkfontdir_1.0.7.bb
meta/recipes-graphics/xorg-font/font-alias_1.0.3.bb
meta/recipes-graphics/xorg-font/font-util_1.3.0.bb

index cf2a78e02ccdfddaf11d0423090cb17ee6bbe626..9365475bcca27b427dae4639b31641420017f31b 100644 (file)
@@ -27,7 +27,7 @@ inherit autotools pkgconfig binconfig
 
 LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
 EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
-EXTRA_OEMAKE_virtclass-native = ""
+EXTRA_OEMAKE_class-native = ""
 EXTRA_OECONF = "--without-zlib --without-bzip2"
 
 do_configure() {
@@ -40,7 +40,7 @@ do_configure() {
        oe_runconf
 }
 
-do_configure_virtclass-native() {
+do_configure_class-native() {
        (cd builds/unix && gnu-configize) || die "failure running gnu-configize"
        oe_runconf
 }
index d5c127d2c5161bb5f1d94eea764666275e0027b3..e25c597a07c39dff67c62cd8d0471eb8b24899b0 100644 (file)
@@ -16,7 +16,7 @@ DEPENDS = "${@base_contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)} \
            ${@base_contains('DISTRO_FEATURES', 'opengl', 'virtual/libgl', '', d)} \
            ${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxext libxrandr libxrender', '', d)} \
            tslib"
-DEPENDS_virtclass-nativesdk = "${@base_contains('DISTRO_FEATURES', 'x11', 'nativesdk-libx11 nativesdk-libxrandr nativesdk-libxrender nativesdk-libxext', '', d)}"
+DEPENDS_class-nativesdk = "${@base_contains('DISTRO_FEATURES', 'x11', 'nativesdk-libx11 nativesdk-libxrandr nativesdk-libxrender nativesdk-libxext', '', d)}"
 
 PR = "r1"
 
index b36197895c101eff0c7e8938a0c3661312e3df75..839c00d933a9f77a5bf13a4cf080618075eb7ffd 100644 (file)
@@ -16,7 +16,7 @@ PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
 PACKAGECONFIG[x11] = "--with-x,--without-x,${X11DEPENDS}"
 
 BBCLASSEXTEND = "native"
-DEPENDS_virtclass-native = "glib-2.0-native cairo-native"
+DEPENDS_class-native = "glib-2.0-native cairo-native"
 
 PACKAGES_DYNAMIC += "^pango-module-.*"
 
index feb9e4dd53bca5389c64dbb7ce15845031edfacd..2e1b57bae49d953987ff29f6eac20a34c87b4aba 100644 (file)
@@ -21,5 +21,5 @@ FILES_python-xcbgen = "${libdir}/python*"
 RDEPENDS_${PN}-dev = ""
 RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
 
-DEPENDS_append_virtclass-native = " python-native"
+DEPENDS_append_class-native = " python-native"
 BBCLASSEXTEND = "native nativesdk"
index 66373261317399709ef3fb47b2dfdcc87d4d8000..a453e24876f66cea09bbb0457f1affa13e3ec16f 100644 (file)
@@ -12,7 +12,7 @@ PE = "1"
 PR = "${INC_PR}.0"
 
 RDEPENDS_${PN} += "mkfontscale"
-RDEPENDS_${PN}_virtclass-native += "mkfontscale-native"
+RDEPENDS_${PN}_class-native += "mkfontscale-native"
 
 BBCLASSEXTEND = "native"
 
index a212f1964a8968627d1f5aacfaa30e51822ce2bc..2c51cbbeb27768c100d7e23683e08b4b6b45d150 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI += "file://nocompiler.patch"
 
 DEPENDS = "util-macros-native"
 RDEPENDS_${PN} = "encodings font-util"
-RDEPENDS_${PN}_virtclass-native = "font-util-native"
+RDEPENDS_${PN}_class-native = "font-util-native"
 
 inherit allarch
 
index 180c7dd49eb9b33d1e2549584b80775e059f40a8..723cb0ccd95986d8e6fe92d877be7b3f0dcbd5ba 100644 (file)
@@ -10,9 +10,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c0067273d90f6336008cb2504e14bd32 \
                     file://map-ISO8859-1;beginline=9;endline=23;md5=1cecb984063248f29ffe5c46f5c04f34"
 
 DEPENDS = "encodings util-macros"
-DEPENDS_virtclass-native = "util-macros-native"
+DEPENDS_class-native = "util-macros-native"
 RDEPENDS_${PN} = "mkfontdir mkfontscale encodings"
-RDEPENDS_${PN}_virtclass-native = "mkfontdir-native mkfontscale-native"
+RDEPENDS_${PN}_class-native = "mkfontdir-native mkfontscale-native"
 
 PR = "${INC_PR}.0"