]> code.ossystems Code Review - openembedded-core.git/commitdiff
packages: check, uuid and xerces.
authorJoshua Lock <josh@linux.intel.com>
Wed, 29 Oct 2008 16:32:03 +0000 (16:32 +0000)
committerJoshua Lock <josh@linux.intel.com>
Wed, 29 Oct 2008 16:34:47 +0000 (16:34 +0000)
Add recipes for: updated check, 0.9.5
uuid 1.6.2
xerces-c 2.8.0

meta/packages/check/check_0.9.5.bb [new file with mode: 0644]
meta/packages/check/files/configure_fix.patch [new file with mode: 0644]
meta/packages/uuid/files/fixes.patch [new file with mode: 0644]
meta/packages/uuid/uuid_1.6.2.bb [new file with mode: 0644]
meta/packages/xerces-c/xerces-c_2.8.0.bb [new file with mode: 0644]

diff --git a/meta/packages/check/check_0.9.5.bb b/meta/packages/check/check_0.9.5.bb
new file mode 100644 (file)
index 0000000..eccb8b7
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "a unit test framework for C"
+LICENSE = "LGPL"
+PRIORITY = "optional"
+SECTION = "devel"
+
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/check/check-${PV}.tar.gz \
+           file://configure_fix.patch;patch=1"
+S = "${WORKDIR}/check-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--enable-plain-docdir"
+
+do_stage() {
+       autotools_stage_all
+}
+
diff --git a/meta/packages/check/files/configure_fix.patch b/meta/packages/check/files/configure_fix.patch
new file mode 100644 (file)
index 0000000..3e79319
--- /dev/null
@@ -0,0 +1,12 @@
+Index: check-0.9.5/configure.ac
+===================================================================
+--- check-0.9.5.orig/configure.ac      2008-10-29 04:09:50.000000000 +0000
++++ check-0.9.5/configure.ac   2008-10-29 04:10:06.000000000 +0000
+@@ -71,6 +71,7 @@
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_LIBTOOL
++AM_PROG_CC_C_O
+ if test -n "$GCC"; then
+   CFLAGS="$CFLAGS -Wall -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings"
+ fi
diff --git a/meta/packages/uuid/files/fixes.patch b/meta/packages/uuid/files/fixes.patch
new file mode 100644 (file)
index 0000000..8a792c7
--- /dev/null
@@ -0,0 +1,42 @@
+Index: uuid-1.6.2/Makefile.in
+===================================================================
+--- uuid-1.6.2.orig/Makefile.in        2008-10-29 04:37:32.000000000 +0000
++++ uuid-1.6.2/Makefile.in     2008-10-29 04:40:18.000000000 +0000
+@@ -55,7 +55,6 @@
+ CP          = cp
+ RMDIR       = rmdir
+ SHTOOL      = $(S)/shtool
+-LIBTOOL     = $(C)/libtool
+ TRUE        = true
+ POD2MAN     = pod2man
+ PERL        = @PERL@
+Index: uuid-1.6.2/configure.ac
+===================================================================
+--- uuid-1.6.2.orig/configure.ac       2008-10-29 04:31:31.000000000 +0000
++++ uuid-1.6.2/configure.ac    2008-10-29 04:33:07.000000000 +0000
+@@ -40,11 +40,8 @@
+ AC_PROG_MAKE_SET
+ AC_PROG_CC
+-AC_CHECK_DEBUGGING
+-AC_CHECK_DMALLOC
+ with_tags=""
+-sinclude(libtool.m4)
+ AC_PROG_LIBTOOL
+ sinclude(uuid.ac)
+Index: uuid-1.6.2/uuid.ac
+===================================================================
+--- uuid-1.6.2.orig/uuid.ac    2008-10-29 04:31:39.000000000 +0000
++++ uuid-1.6.2/uuid.ac 2008-10-29 04:31:53.000000000 +0000
+@@ -39,9 +39,6 @@
+     fi
+     AC_CHECK_LIB(socket, accept)
+-    dnl #  check for portable va_copy()
+-    AC_CHECK_VA_COPY()
+-
+     dnl #   check for system headers
+     AC_CHECK_HEADERS(sys/types.h sys/param.h sys/time.h sys/socket.h sys/sockio.h sys/ioctl.h sys/select.h)
+     AC_CHECK_HEADERS(netdb.h ifaddrs.h net/if.h net/if_dl.h net/if_arp.h netinet/in.h arpa/inet.h,,,
diff --git a/meta/packages/uuid/uuid_1.6.2.bb b/meta/packages/uuid/uuid_1.6.2.bb
new file mode 100644 (file)
index 0000000..eb76349
--- /dev/null
@@ -0,0 +1,15 @@
+SRC_URI = "ftp://ftp.ossp.org/pkg/lib/uuid/uuid-1.6.2.tar.gz \
+           file://fixes.patch;patch=1"
+PR = "r0"
+
+inherit autotools
+
+do_configure_prepend () {
+       rm libtool.m4
+}
+
+export LIBTOOL = "${S}/${TARGET_PREFIX}libtool"
+
+do_stage () {
+       autotools_stage_all
+}
\ No newline at end of file
diff --git a/meta/packages/xerces-c/xerces-c_2.8.0.bb b/meta/packages/xerces-c/xerces-c_2.8.0.bb
new file mode 100644 (file)
index 0000000..d78bb22
--- /dev/null
@@ -0,0 +1,36 @@
+DESCRIPTION = "Xerces-c is a validating xml parser written in C++"
+HOMEPAGE = "http://xerces.apache.org/xerces-c/"
+SECTION =  "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+PR = "r1"
+
+SRC_URI = "http://mirror.serversupportforum.de/apache/xerces/c/2/sources/xerces-c-src_2_8_0.tar.gz"
+S = "${WORKDIR}/xerces-c-src_2_8_0/src/xercesc"
+
+inherit autotools pkgconfig
+
+CCACHE = ""
+export XERCESCROOT="${WORKDIR}/xerces-c-src_2_8_0"
+export cross_compiling = "yes"
+
+do_configure() {
+       ./runConfigure -plinux -c"${CC}" -x"${CXX}" -minmem -nsocket -tnative -rpthread -P${D}${prefix} \
+                    -C--build=${BUILD_SYS} \
+                    -C--host=${HOST_SYS} \
+                    -C--target=${TARGET_SYS} \
+}
+
+do_compile() {
+       ${MAKE}
+}
+
+do_stage () {
+    oe_libinstall -C ${XERCESCROOT}/lib libxerces-c ${STAGING_LIBDIR}
+    oe_libinstall -C ${XERCESCROOT}/lib libxerces-depdom ${STAGING_LIBDIR}
+    cp -pPR ${XERCESCROOT}/include/xercesc ${STAGING_INCDIR}
+}
+
+do_install () {
+       ${MAKE} install
+}