]> code.ossystems Code Review - openembedded-core.git/commitdiff
connman: avoid checking for linux/if_alg.h header
authorOtavio Salvador <otavio@ossystems.com.br>
Fri, 9 Dec 2011 20:01:33 +0000 (20:01 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 10 Dec 2011 00:03:59 +0000 (00:03 +0000)
Disable building of 'alg-test' and checking for if_alg.h header.

Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/connman/connman.inc
meta/recipes-connectivity/connman/connman_0.78.bb

index d695fee218dcd8260f48018585225f4cc836b58d..503bf1cffa28ce55415cbd8da0b8f7f2b66b0433 100644 (file)
@@ -49,6 +49,14 @@ USERADD_PARAM_${PN} = "--system --no-create-home \
 
 inherit autotools pkgconfig update-rc.d useradd
 
+# alg-test doesn't build, so disable that and test
+# for if_alg.h as this header is only in 2.6.39
+do_configure_prepend() {
+       sed -i 's:tools/alg-test ::g' Makefile.am
+       sed -i 's:AC_CHECK_HEADERS(linux/if_alg.h, dummy=yes,::g;
+               s:AC_MSG_ERROR(User-space algorithm header files are required))::g' configure.ac
+}
+
 do_compile_append() {
        sed -i -e s:deny:allow:g src/connman-dbus.conf
 }
index 5ea2bb7ef246e6387cdf978efb05ed6593107982..378bd9d647e7138d03654e6ef18539c6e8be5926 100644 (file)
@@ -1,6 +1,6 @@
 require connman.inc
 
-PR = "r2"
+PR = "r3"
 
 # 0.78 tag
 SRCREV = "02f5d5fe2d7c71514a6387ba2b772b42d8e8d297"