]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-firmware: Fix file permissions
authorMark Hatle <mark.hatle@windriver.com>
Fri, 24 Jun 2011 18:29:29 +0000 (13:29 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 30 Jun 2011 19:46:17 +0000 (20:46 +0100)
The firmware was installed 0666 which could have been a security
issue.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-kernel/linux-firmware/linux-firmware_git.bb

index 3d822c5ffadc76d78c421395857ee51d7106f96e..29f1e78e4e6ca4479d55bf7c747f8a156bf334ac 100644 (file)
@@ -32,9 +32,9 @@ do_compile() {
 do_install() {
        install -d  ${D}/lib/firmware/
        # Libertas sd8686
-       install -m 0666 libertas/sd8686_v9.bin ${D}/lib/firmware/sd8686.bin
-       install -m 0666 libertas/sd8686_v9_helper.bin ${D}/lib/firmware/sd8686_helper.bin
-       install -m 0666 LICENCE.libertas ${D}/lib/firmware/
+       install -m 0644 libertas/sd8686_v9.bin ${D}/lib/firmware/sd8686.bin
+       install -m 0644 libertas/sd8686_v9_helper.bin ${D}/lib/firmware/sd8686_helper.bin
+       install -m 0644 LICENCE.libertas ${D}/lib/firmware/
 }
 
 PACKAGES = "${PN}-sd8686"