]> code.ossystems Code Review - openembedded-core.git/commitdiff
update-rc.d: fix metadate
authorQing He <qing.he@intel.com>
Sat, 12 Jun 2010 08:34:36 +0000 (16:34 +0800)
committerJoshua Lock <josh@linux.intel.com>
Thu, 17 Jun 2010 22:16:41 +0000 (23:16 +0100)
update license fields
adjust ordering
change to use new patch parameter

Signed-off-by: Qing He <qing.he@intel.com>
Signed-off-by: Kevin Tian <kevin.tian@intel.com>
meta/packages/update-rc.d/update-rc.d_0.7.bb

index cc6948f4df44ead219e89f092cecee0628508577..7f68d866deb69f83a7475017641ebf4c99a1cc49 100644 (file)
@@ -1,14 +1,18 @@
+DESCRIPTION = "manage symlinks in /etc/rcN.d."
 SECTION = "base"
 PRIORITY = "standard"
-DESCRIPTION = "Manage symlinks in /etc/rcN.d"
-LICENSE = "GPL"
-S = "${WORKDIR}/update-rc.d"
+PACKAGE_ARCH = "all"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://update-rc.d;beginline=5;endline=15;md5=148a48321b10eb37c1fa3ee02b940a75"
+
 PR = "r3"
 
 SRC_URI = "${HANDHELDS_CVS};module=apps/update-rc.d;tag=r0_7 \
-           file://add-verbose.patch;patch=1"
+           file://add-verbose.patch;apply=yes"
+
+S = "${WORKDIR}/update-rc.d"
 
-PACKAGE_ARCH = "all"
 
 do_compile() {
 }
@@ -19,4 +23,4 @@ do_install() {
        install -m 0755 ${S}/update-rc.d ${D}${sbindir}/update-rc.d
 }
 
-BBCLASSEXTEND = "native"
\ No newline at end of file
+BBCLASSEXTEND = "native"