]> code.ossystems Code Review - openembedded-core.git/commitdiff
db: Fix libtool linking against local libstdc++.so
authorTyler Hall <tylerwhall@gmail.com>
Sat, 25 Jan 2014 04:14:03 +0000 (23:14 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 30 Jan 2014 15:00:58 +0000 (15:00 +0000)
Building the C++ bindings in a484b35b818768487ff27cf06b8c5d4e128126af
introduced this error on systems with /usr/lib/libstdc++.so present:

    /usr/lib/libstdc++.so: file not recognized: File format not recognized

The shipped libtool is sysroot aware, so pass --with-sysroot so it will
extract the sysroot from the compiler.

Signed-off-by: Tyler Hall <tylerwhall@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/db/db_5.3.21.bb

index 8ec887007a9d6f78b510894e788d17c33dff6ca9..caf68902612ed30bc3a8a117370f8a9260a44c45 100644 (file)
@@ -63,7 +63,7 @@ FILES_SOLIBSDEV = "${libdir}/libdb.so ${libdir}/libdb_cxx.so"
 # All the --disable-* options replace --enable-smallbuild, which breaks a bunch of stuff (eg. postfix)
 DB5_CONFIG ?= "--enable-o_direct --disable-cryptography --disable-queue --disable-replication --disable-verify --disable-compat185 --disable-sql"
 
-EXTRA_OECONF = "${DB5_CONFIG} --enable-shared --enable-cxx"
+EXTRA_OECONF = "${DB5_CONFIG} --enable-shared --enable-cxx --with-sysroot"
 
 # Override the MUTEX setting here, the POSIX library is
 # the default - "POSIX/pthreads/library".