]> code.ossystems Code Review - openembedded-core.git/commitdiff
libmodule-build-perl: fix ptests
authorAlexander Kanavin <alex.kanavin@gmail.com>
Wed, 8 Jan 2020 13:27:59 +0000 (14:27 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 10 Jan 2020 20:32:04 +0000 (20:32 +0000)
Particularly remove a broken detection of skipped tests
(which was marking tests that actually passed), and install
additional artefacts needed for testing.

Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/perl/libmodule-build-perl/run-ptest
meta/recipes-devtools/perl/libmodule-build-perl_0.4229.bb

index 0d63d1513bc6178a4330015a3c502497df12d162..d802781f9e6f1086975cdf7ffb3c7eb80dc7b45c 100644 (file)
@@ -6,8 +6,6 @@ for case in `find t -type f -name '*.t'`; do
     cat $case.output
     if [ $ret -ne 0 ]; then
         echo "FAIL: ${case%.t}"
-    elif grep -i 'SKIP' $case.output; then
-        echo "SKIP: ${case%.t}"
     else
         echo "PASS: ${case%.t}"
     fi
index f759f862fb2519b0b2393c9b31ce184a8aea4b87..e3ba40d96c53ab0296eef43767f43fadceda61f1 100644 (file)
@@ -36,7 +36,10 @@ do_patch[postfuncs] += "do_patch_module_build"
 do_install_ptest() {
        cp -r ${B}/inc ${D}${PTEST_PATH}
        cp -r ${B}/blib ${D}${PTEST_PATH}
+       cp -r ${B}/_build ${D}${PTEST_PATH}
+       cp -r ${B}/lib ${D}${PTEST_PATH}
        chown -R root:root ${D}${PTEST_PATH}
+       sed -i -e "s,'perl' => .*,'perl' => '/usr/bin/perl'\,,g" ${D}${PTEST_PATH}/_build/build_params
 }
 
 RDEPENDS_${PN} += " \