]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxsettings: Include libxt in DEPENDS as without it, configure pulls in system direc...
authorRichard Purdie <richard@openedhand.com>
Fri, 31 Mar 2006 09:21:51 +0000 (09:21 +0000)
committerRichard Purdie <richard@openedhand.com>
Fri, 31 Mar 2006 09:21:51 +0000 (09:21 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@343 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/libxsettings-client/libxsettings-client-0.16/Makefile-am.patch [new file with mode: 0644]
openembedded/packages/libxsettings-client/libxsettings-client_0.14.bb
openembedded/packages/libxsettings-client/libxsettings-client_0.16.bb [new file with mode: 0644]

diff --git a/openembedded/packages/libxsettings-client/libxsettings-client-0.16/Makefile-am.patch b/openembedded/packages/libxsettings-client/libxsettings-client-0.16/Makefile-am.patch
new file mode 100644 (file)
index 0000000..fb5b1db
--- /dev/null
@@ -0,0 +1,11 @@
+--- libxsettings-client-0.16/Makefile.am.orig  2006-01-17 16:01:21.000000000 +0000
++++ libxsettings-client-0.16/Makefile.am       2006-01-17 16:01:30.000000000 +0000
+@@ -3,7 +3,7 @@
+ source_h = xsettings-client.h  xsettings-common.h
+ source_c = xsettings-client.c  xsettings-common.c
+-INCLUDES = -I $(includedir) $(X_CFLAGS)
++INCLUDES = $(X_CFLAGS)
+ libxsincludedir = $(includedir)
index 7e1b4df2c449df58c8aef884ead79401b8893a2b..f2e77735f91adc99ee6ed5821d1a53b30dd76f0b 100644 (file)
@@ -1,17 +1,15 @@
 SECTION = "gpe/libs"
 LICENSE = "BSD-X"
 PRIORITY = "optional"
-DEPENDS = "libxsettings libx11"
-PR = "r1"
+DEPENDS = "libxsettings libx11 libxt"
+# libxt is required to stop configure breaking builds by
+# including system paths to find it if it isn't present.
 
 inherit autotools pkgconfig gpe
 
 SRC_URI = "${GPE_MIRROR}/xsettings-client-${PV}.tar.bz2"
 S = ${WORKDIR}/xsettings-client-${PV}
 
-do_configure () {
-       X_LIBS=" -L${STAGING_LIBDIR}" oe_runconf
-}
 
 headers = "xsettings-client.h xsettings-common.h"
 do_stage () {
@@ -21,4 +19,3 @@ do_stage () {
                 install -m 0644 ${S}/$h ${STAGING_INCDIR}/$h
         done
 }
-
diff --git a/openembedded/packages/libxsettings-client/libxsettings-client_0.16.bb b/openembedded/packages/libxsettings-client/libxsettings-client_0.16.bb
new file mode 100644 (file)
index 0000000..45d9b1c
--- /dev/null
@@ -0,0 +1,24 @@
+SECTION = "gpe/libs"
+LICENSE = "BSD-X"
+PRIORITY = "optional"
+DEPENDS = "libxsettings libx11 libxt"
+# libxt is required to stop configure breaking builds by 
+# including system paths to find it if it isn't present.
+MAINTAINER = "Florian Boor <florian@kernelconcepts.de>"
+PR="r1"
+
+inherit autotools pkgconfig gpe
+
+SRC_URI = "${GPE_MIRROR}/libxsettings-client-${PV}.tar.bz2 \
+       file://Makefile-am.patch;patch=1"
+
+
+headers = "xsettings-client.h xsettings-common.h"
+do_stage () {
+        oe_libinstall -so libXsettings-client ${STAGING_LIBDIR}
+        mkdir -p ${STAGING_INCDIR}
+        for h in ${headers}; do
+               install -m 0644 ${S}/$h ${STAGING_INCDIR}/$h
+        done
+}
+