]> code.ossystems Code Review - openembedded-core.git/commitdiff
webkitgtk: fix build with musl and x32
authorAnuj Mittal <anuj.mittal@intel.com>
Fri, 29 Dec 2017 02:00:12 +0000 (10:00 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 4 Jan 2018 12:54:43 +0000 (12:54 +0000)
Make the x32 check generic to make it work with musl as well.

Fixes [YOCTO #12118]

Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-sato/webkit/webkitgtk_2.18.3.bb

index 00b5a15e085146983d88ab03e1d108e918a6d047..4938f69b7b6e855b3708699baf06b36edfa7b54f 100644 (file)
@@ -66,6 +66,7 @@ EXTRA_OECMAKE = " \
 
 # GL/GLES header clash: both define the same thing, differently, on 32 bit x86
 EXTRA_OECMAKE_append_x86 = " -DUSE_GSTREAMER_GL=OFF "
+EXTRA_OECMAKE_append_x86-x32 = " -DUSE_GSTREAMER_GL=OFF "
 
 # Javascript JIT is not supported on powerpc
 EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF "
@@ -92,7 +93,7 @@ EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF "
 # An attempt was made to upstream JIT support for x32 in
 # https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as
 # unresolved due to limited X32 adoption.
-EXTRA_OECMAKE_append_linux-gnux32 = " -DENABLE_JIT=OFF"
+EXTRA_OECMAKE_append_x86-x32 = " -DENABLE_JIT=OFF "
 
 SECURITY_CFLAGS_remove_aarch64 = "-fpie"
 SECURITY_CFLAGS_append_aarch64 = " -fPIE"