]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemugl: make postinst run at first boot
authorScott Garman <scott.a.garman@intel.com>
Tue, 17 Apr 2012 23:10:30 +0000 (23:10 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 17 Apr 2012 23:21:51 +0000 (00:21 +0100)
The previous postinst script was not working for images which use
RPM because do_rootfs could allow qemugl to be installed after
libgl1, and the postinst needs to run after libgl1 is installed.

Hence, it's being changed to run at first boot instead of during
do_rootfs.

Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/mesa/qemugl_git.bb

index 378aa6550234595007636c0d5f2d55a409d59b2b..32980d319d4f427bb5f5275d7768ae364ee48ef6 100644 (file)
@@ -19,7 +19,7 @@ S = "${WORKDIR}/git"
 SRCREV = "d888bbc723c00d197d34a39b5b7448660ec1b1c0"
 
 PV = "0.0+git${SRCPV}"
-PR = "r10"
+PR = "r11"
 
 DEFAULT_PREFERENCE = "-1"
 
@@ -34,11 +34,17 @@ do_install () {
     fi
 }
 
+# This cannot be converted to run at pacakge install time, because
+# it depends on being run after the libgl1 package is installed,
+# and RPM cannot guarantee the order of pacakge insallation.
 pkg_postinst_${PN} () {
-    if [ "${PN}" != "qemugl-nativesdk" ]; then
-        rm -f $D${libdir}/libGL.so.1.2
-        ln -s libGL-qemu.so.1.2 $D${libdir}/libGL.so.1.2
-    fi
+#!/bin/sh -e
+if [ x"$D" = "x" ]; then
+       rm -f ${libdir}/libGL.so.1.2
+       ln -s libGL-qemu.so.1.2 ${libdir}/libGL.so.1.2
+else
+       exit 1
+fi
 }
 
 BBCLASSEXTEND = "nativesdk"