]> code.ossystems Code Review - openembedded-core.git/commitdiff
bison-native: create a wrapper script for sstate installation
authorKevin Tian <kevin.tian@intel.com>
Wed, 5 Jan 2011 03:04:12 +0000 (11:04 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 7 Jan 2011 11:09:49 +0000 (11:09 +0000)
bison-native encodes M4 and PKGDATA staging path in its binary, which
breaks sstate installation in a new build environment. Use create_wrapper
similar as flex-native to solve this issue

Signed-off-by: Kevin Tian <kevin.tian@intel.com>
meta/recipes-devtools/bison/bison_2.4.3.bb

index 03fd463fd8bd824a7679ee05dbc7d567e2bcbcf4..fa2f15400ab70a95082af518481861831b2fb831 100644 (file)
@@ -10,7 +10,7 @@ SECTION = "devel"
 PRIORITY = "optional"
 DEPENDS = "gettext bison-native"
 
-PR = "r0"
+PR = "r1"
 
 BASE_SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.gz \
           file://m4.patch;patch=1"
@@ -27,4 +27,10 @@ SRC_URI_virtclass-native = "${BASE_SRC_URI}"
 inherit autotools
 acpaths = "-I ${S}/m4"
 
+do_install_append_virtclass-native() {
+       create_wrapper ${D}/${bindir}/bison \
+               M4=${STAGING_BINDIR_NATIVE}/m4 \
+               BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
+}
+#bison-native encodes the staging M4 path
 BBCLASSEXTEND = "native"