]> code.ossystems Code Review - openembedded-core.git/commitdiff
qt4: fix incorrect architecture for qt4 tools
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Tue, 3 Jan 2012 13:41:32 +0000 (13:41 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 4 Jan 2012 12:08:12 +0000 (12:08 +0000)
Don't install the native staging versions of the qt4 tools in the bin
directory; we have been doing this for a very long time but it is no
longer necessary since we specify them via the QMAKE_UIC, QMAKE_MOC etc.
variables. Doing so was sometimes resulting in those executables being
the ones that end up being packaged (probably only sometimes due to
different date/time values on the staging files and the interaction
with make).

Fixes [YOCTO #1856].

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-qt/qt4/qt-4.7.4.inc
meta/recipes-qt/qt4/qt4-embedded_4.7.4.bb
meta/recipes-qt/qt4/qt4-x11-free_4.7.4.bb

index 8fda9ce85aafd14541c62b68f090340ac7942af9..9ddb055777081df9fb3e8274a4774344d430e1bf 100644 (file)
@@ -50,10 +50,6 @@ do_compile() {
     fi
 
     unset CFLAGS CXXFLAGS
-    install -m 0755 ${STAGING_BINDIR_NATIVE}/rcc4 ${S}/bin/rcc
-    install -m 0755 ${STAGING_BINDIR_NATIVE}/moc4 ${S}/bin/moc
-    install -m 0755 ${STAGING_BINDIR_NATIVE}/uic4 ${S}/bin/uic
-    install -m 0755 ${STAGING_BINDIR_NATIVE}/lrelease4 ${S}/bin/lrelease
 
     oe_runmake ${EXTRA_ENV}
 }
index 1d7104c5bcc1e580a7cf155f6a524b2e0c730151..9b66d0327cad05ee062665b80772b940a31306ba 100644 (file)
@@ -1,7 +1,7 @@
 require qt-${PV}.inc
 require qt4-embedded.inc
 
-PR = "${INC_PR}.5"
+PR = "${INC_PR}.6"
 
 QT_CONFIG_FLAGS_append_armv6 = " -no-neon "
 
index 3263c937099c91667957bc9a2eddde4e52a8a57f..6dedf0048a0b240cf07c55271954eb62b346f6b7 100644 (file)
@@ -1,7 +1,7 @@
 require qt4-x11-free.inc
 require qt-${PV}.inc
 
-PR = "${INC_PR}.5"
+PR = "${INC_PR}.6"
 
 QT_CONFIG_FLAGS_append_armv6 = " -no-neon "