]> code.ossystems Code Review - openembedded-core.git/commitdiff
ca-certificates: Fix openssl runtime dependencies
authorAndrei Gherzan <andrei@gherzan.ro>
Thu, 30 May 2019 12:22:23 +0000 (13:22 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 31 May 2019 14:36:16 +0000 (15:36 +0100)
Since yocto thud, and more specifically since poky switched to
openssl 1.1 line, the openssl binary is provided by 'openssl-bin'. This
impacts the native and nativesdk recipe variants as well.

Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/ca-certificates/ca-certificates_20190110.bb

index 4c0425302f14169562d4ac964291470a606ddc5e..efd9eaa71e4c1ccac4175e85fd7d4c5d82299e5d 100644 (file)
@@ -82,6 +82,8 @@ do_install_append_class-native () {
     SYSROOT="${D}${base_prefix}" ${D}${sbindir}/update-ca-certificates
 }
 
-RDEPENDS_${PN} += "openssl"
+RDEPENDS_${PN}_class-target = "openssl-bin"
+RDEPENDS_${PN}_class-native = "openssl-native"
+RDEPENDS_${PN}_class-nativesdk = "nativesdk-openssl-bin"
 
 BBCLASSEXTEND = "native nativesdk"