]> code.ossystems Code Review - openembedded-core.git/commitdiff
busybox: fix conflict with runlevel applet
authorAndrej Valek <andrej.valek@siemens.com>
Tue, 9 Oct 2018 12:56:38 +0000 (14:56 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 10 Oct 2018 11:42:40 +0000 (12:42 +0100)
- remove OE runlevel script which conflicts with busybox's applet
- don't install empty directories

Signed-off-by: Andrej Valek <andrej.valek@siemens.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/busybox/busybox.inc
meta/recipes-core/busybox/busybox/init.cfg
meta/recipes-core/busybox/busybox_1.29.2.bb
meta/recipes-core/busybox/files/runlevel [deleted file]

index e1fba4243a13ac408ba736179e52148c617485a7..7b427ab0f791799a5ad04c0fbbae859100780c00 100644 (file)
@@ -254,8 +254,7 @@ do_install () {
                        ln -sf busybox ${D}${base_bindir}/busybox.nosuid
                fi
        else
-               install -d ${D}${base_bindir} ${D}${base_sbindir}
-               install -d ${D}${libdir} ${D}${bindir} ${D}${sbindir}
+               install -d ${D}${base_bindir} ${D}${bindir} ${D}${libdir}
                cat busybox.links | while read FILE; do
                        NAME=`basename "$FILE"`
                        install -m 0755 "0_lib/$NAME" "${D}$FILE.${BPN}"
@@ -316,7 +315,6 @@ do_install () {
         if grep "CONFIG_INIT=y" ${B}/.config; then
                 install -D -m 0777 ${WORKDIR}/rcS ${D}${sysconfdir}/init.d/rcS
                 install -D -m 0777 ${WORKDIR}/rcK ${D}${sysconfdir}/init.d/rcK
-                install -D -m 0755 ${WORKDIR}/runlevel ${D}${base_sbindir}/runlevel
         fi
 
     if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
index 3c1fdd42b63f34adc6e2fc110e709965761f4359..b69fe0ea9c019cd00cdc1fa8d5ea85646380cadb 100644 (file)
@@ -1,4 +1,5 @@
 CONFIG_INIT=y
+CONFIG_RUNLEVEL=y
 CONFIG_FEATURE_USE_INITTAB=y
 CONFIG_HALT=y
 CONFIG_POWEROFF=y
index 3496a857c4f5b843f0652610b6fafdd58b0586ca..df3ea5906b526650852feb87101eb8aa7a13b157 100644 (file)
@@ -40,7 +40,6 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
            file://inittab \
            file://rcS \
            file://rcK \
-           file://runlevel \
            file://makefile-libbb-race.patch \
 "
 SRC_URI_append_libc-musl = " file://musl.cfg "
diff --git a/meta/recipes-core/busybox/files/runlevel b/meta/recipes-core/busybox/files/runlevel
deleted file mode 100644 (file)
index 866f3b5..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh
-# busybox init does not have LSB ( sysvinit ) like initlevels
-# so lets fake it to 5 which is what we default anyway
-# this helps with opkg post installs where it tries to invoke
-# update-rc.d ad post install step.
-# for package upgrades
-# See code in update-rc.d around line 190 where it calls runlevel
-# program
-#
-echo "5"
-