]> code.ossystems Code Review - openembedded-core.git/commitdiff
strace: fix ptests
authorAnuj Mittal <anuj.mittal@intel.com>
Fri, 5 Oct 2018 11:24:01 +0000 (19:24 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 9 Oct 2018 11:02:41 +0000 (12:02 +0100)
* Let automake use parallel test harness which ensures that appropriate
environment variables are actually used.

* Copy generated config.h as part of ptest package and define a variable
in tests Makefile to control the name of target that we'd like to
invoke for tests instead of relying on default value.

* configure relies on tools that are not available in release tarballs
resulting in warnings and failed tests. Get the required information
from available files instead.

* Reduces the count of failing tests to 18 from 35. The rest of
tests fail or get skipped mostly because of missing syscalls. Number of
tests getting skipped can probably be reduced further.

Fixes [YOCTO #12948]

Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/strace/strace/Makefile-ptest.patch
meta/recipes-devtools/strace/strace/disable-git-version-gen.patch
meta/recipes-devtools/strace/strace/run-ptest
meta/recipes-devtools/strace/strace_4.24.bb

index a12f4c3e45869593f153f77bd43798e165160522..460b6e26ee11a3bd3a964d6eb1b778fa5ed08ce8 100644 (file)
@@ -1,36 +1,31 @@
-From 0574ae9926308dcbca78bd8cd0f0f143f19cbcb5 Mon Sep 17 00:00:00 2001
+From 207fc7814bbeb0241382329215d21fd3b57066f9 Mon Sep 17 00:00:00 2001
 From: Gabriel Barbu <gabriel.barbu@enea.com>
 Date: Thu, 25 Jul 2013 15:28:33 +0200
-Subject: [PATCH 4/8] strace: Add ptest
+Subject: [PATCH] strace: Add ptest
 
 Upstream-Status: Inappropriate
 
 Signed-off-by: Gabriel Barbu <gabriel.barbu@enea.com>
 Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
+Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
 
 ---
- configure.ac      |  2 +-
- tests/Makefile.am | 18 ++++++++++++++++++
- 2 files changed, 19 insertions(+), 1 deletion(-)
+ tests/Makefile.am | 19 +++++++++++++++++++
+ 1 file changed, 19 insertions(+)
 
-diff --git a/configure.ac b/configure.ac
-index 5f0aec4..8eaacc6 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -42,7 +42,7 @@ AC_COPYRIGHT([Copyright (c) 1999-]copyright_year[ The strace developers.])
- AC_CONFIG_SRCDIR([strace.c])
- AC_CONFIG_AUX_DIR([.])
- AC_CONFIG_HEADERS([config.h])
--AM_INIT_AUTOMAKE([foreign nostdinc dist-xz silent-rules parallel-tests 1.13])
-+AM_INIT_AUTOMAKE([foreign nostdinc dist-xz silent-rules serial-tests 1.13])
- AM_MAINTAINER_MODE
- AC_CANONICAL_HOST
 diff --git a/tests/Makefile.am b/tests/Makefile.am
-index b4ba22a..5836438 100644
+index a2f3950..4fa97e2 100644
 --- a/tests/Makefile.am
 +++ b/tests/Makefile.am
-@@ -408,3 +408,21 @@ BUILT_SOURCES = ksysent.h
+@@ -34,6 +34,7 @@ SIZEOF_LONG = @SIZEOF_LONG@
+ MPERS_NAME =
+ MPERS_CC_FLAGS =
+ ARCH_MFLAGS =
++TEST_SUITE_LOG = test-suite.log
+ AM_CFLAGS = $(WARN_CFLAGS)
+ AM_CPPFLAGS = $(ARCH_MFLAGS) \
+             -I$(builddir) \
+@@ -490,3 +491,21 @@ BUILT_SOURCES = ksysent.h
  CLEANFILES = ksysent.h
  
  include ../scno.am
index 47b1139c531cef71b07d3294b1a423ddb81fcbcb..9e5ec11097db442590857bf2ed5b05e7f1ae938e 100644 (file)
@@ -1,15 +1,25 @@
-The git-version-gen script is not included in tarball releases,
-so we need to avoid attempts to call it when running autoreconf.
+From bee0680754730498485e24dd037303318c68916c Mon Sep 17 00:00:00 2001
+From: Andre McCurdy <armccurdy@gmail.com>
+Date: Mon, 18 Jan 2016 13:33:50 -0800
+Subject: [PATCH] strace: remove need for scripts
+
+git-version-gen copyright-year-gen file-date-gen are not included in
+tarball releases, so we need to avoid attempts to call them.
 
 Upstream-Status: Inappropriate [configuration]
 
 Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
+Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
+
+---
+ configure.ac | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
 
-Index: strace-4.22/configure.ac
-===================================================================
---- strace-4.22.orig/configure.ac
-+++ strace-4.22/configure.ac
-@@ -32,7 +32,7 @@
+diff --git a/configure.ac b/configure.ac
+index ad1d00f..96fa205 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -32,12 +32,12 @@
  
  AC_PREREQ(2.57)
  AC_INIT([strace],
@@ -18,3 +28,10 @@ Index: strace-4.22/configure.ac
        [strace-devel@lists.strace.io],
        [strace],
        [https://strace.io])
+-m4_define([copyright_year], m4_esyscmd([./copyright-year-gen .year]))
+-m4_define([manpage_date], m4_esyscmd([./file-date-gen strace.1.in]))
++m4_define([copyright_year], m4_esyscmd_s([cat .year]))
++m4_define([manpage_date], m4_esyscmd_s([cat .strace.1.in.date]))
+ AC_COPYRIGHT([Copyright (c) 1999-]copyright_year[ The strace developers.])
+ AC_CONFIG_SRCDIR([strace.c])
+ AC_CONFIG_AUX_DIR([.])
index 133cf92d02bcd2003f8701a7c78c5aa6ba731ae1..8070d831799ec7d5dd63020469c9c0b7a2887138 100755 (executable)
@@ -1,2 +1,2 @@
 #!/bin/sh
-make -C tests -k runtest-TESTS
+make -B -C tests -k test-suite.log
index e6f7e9cba7832b756951f76d3f64d22cab2a0443..9e40a064f8e29876a6843da854e482dd90c07073 100644 (file)
@@ -44,6 +44,8 @@ do_compile_ptest() {
 
 do_install_ptest() {
        oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
+       install -m 755 ${S}/test-driver ${D}${PTEST_PATH}
+       install -m 644 ${B}/config.h ${D}${PTEST_PATH}
        sed -i -e '/^src/s/strace.*[1-9]/ptest/' \
            -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
            -e 's|${DEBUG_PREFIX_MAP}||g' \