]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu: force build type to production
authorJoe Slater <joe.slater@windriver.com>
Mon, 1 Jun 2020 22:30:17 +0000 (15:30 -0700)
committerSteve Sakoman <steve@sakoman.com>
Tue, 16 Jun 2020 20:14:02 +0000 (10:14 -1000)
qemu will not build for -Og optimization because macros
in lockable.h expect dead-code elimination.  Override DEBUG_BUILD.

Signed-off-by: Joe Slater <joe.slater@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit ad404b2e51223625bd95f9a7da4c7a690c37bdfb)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-devtools/qemu/qemu_4.2.0.bb

index f0c1daabe15032e23cf8ac43ad80756e763687ec..9c761447497406290b7a70a767eb49de95c87984 100644 (file)
@@ -10,6 +10,11 @@ DEPENDS = "glib-2.0 zlib pixman bison-native"
 
 RDEPENDS_${PN}_class-target += "bash"
 
+# Does not compile for -Og because that level does not clean up dead-code.
+# See lockable.h.
+#
+DEBUG_BUILD = "0"
+
 EXTRA_OECONF_append_class-target = " --target-list=${@get_qemu_target_list(d)}"
 EXTRA_OECONF_append_class-target_mipsarcho32 = "${@bb.utils.contains('BBEXTENDCURR', 'multilib', ' --disable-capstone', '', d)}"
 EXTRA_OECONF_append_class-nativesdk = " --target-list=${@get_qemu_target_list(d)}"