]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: kill -Werror
authorFahad Usman <fahad_usman@mentor.com>
Wed, 12 Dec 2012 07:08:37 +0000 (12:08 +0500)
committerSaul Wold <sgw@linux.intel.com>
Fri, 14 Dec 2012 23:17:20 +0000 (15:17 -0800)
this fails to build using a recent sourcery toolchain due to
unused-but-set-variable

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
the patch was imported from meta-mentor layer on yoctoproject git server
http://git.yoctoproject.org/cgit/cgit.cgi/meta-mentor as of commit ids
82e96b3baa1c64d03412871fce56d496a338f167 and
ae325d011bd50501fe677c8b37295ae83030c526

Signed-off-by: Fahad Usman <fahad_usman@mentor.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-kernel/perf/perf_3.4.bb

index b09436231fde81ae7f6470f123977712598b5d72..4e6d03d00507a7faf7a37d455dbbac94651e9d6a 100644 (file)
@@ -9,7 +9,7 @@ as well."
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
 
-PR = "r5"
+PR = "r6"
 
 require perf.inc
 
@@ -79,6 +79,10 @@ do_install() {
        fi
 }
 
+do_configure_prepend () {
+    sed -i 's,-Werror ,,' ${S}/tools/perf/Makefile
+}
+
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 FILES_${PN} += "${libexecdir}/perf-core"