]> code.ossystems Code Review - openembedded-core.git/commitdiff
patch: use PACKAGECONFIG to ensure correct dependency for xattr
authorSaul Wold <sgw@linux.intel.com>
Wed, 22 May 2013 02:14:23 +0000 (02:14 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 30 May 2013 19:45:48 +0000 (20:45 +0100)
This will enable or disable xattr with the correct dependency
on attr as needed.

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/patch/patch_2.7.1.bb

index b13120414d420f57a5e98d3d2a06b75132501c01..4fc137e5729a9686dcaae25273c3a94fc4005dd6 100644 (file)
@@ -10,4 +10,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
 
 acpaths = "-I ${S}/m4 "
 
-EXTRA_OECONF += "--disable-xattr"
+PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'xattr', 'xattr', '', d)}"
+PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr," 
+