]> code.ossystems Code Review - openembedded-core.git/commitdiff
matchbox-sato: use formfactor to determine if we should show a cursor
authorRoss Burton <ross@openedhand.com>
Fri, 16 Nov 2007 15:53:14 +0000 (15:53 +0000)
committerRoss Burton <ross@openedhand.com>
Fri, 16 Nov 2007 15:53:14 +0000 (15:53 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3190 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session
meta/packages/matchbox-sato/matchbox-sato_0.1.bb

index 8d095f3cd4c89263a3f62f29bb62dfc4a88c75c6..8a2bdd013a45fe9978aec26a922c68bc1934bd35 100755 (executable)
@@ -1,6 +1,12 @@
 #!/bin/sh
 
-SHOWCURSOR="no"
+. /etc/formfactor/config
+
+if [ "$HAVE_TOUCHSCREEN" = "1" ]; then
+    SHOWCURSOR="no"
+else
+    SHOWCURSOR="yes"
+fi
 
 matchbox-desktop &
 
index bf39d735712fdd2fc00ba2d96f153225a73f2081..78598ce63d372c0018e48203cdd042a9a7f01b65 100644 (file)
@@ -1,9 +1,9 @@
 DESCRIPTION = "Custom MB session files for poky"
 LICENSE = "GPL"
 SECTION = "x11"
-RDEPENDS = "gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato"
+RDEPENDS = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato"
 RCONFLICTS = "matchbox-common"
-PR = "r16"
+PR = "r17"
 
 SRC_URI = "file://etc file://matchbox-session"
 S = ${WORKDIR}