]> code.ossystems Code Review - openembedded-core.git/commitdiff
parted: 1.88 -> 1.9.0 (works with recent autoconf/automake)
authorRichard Purdie <rpurdie@linux.intel.com>
Tue, 2 Feb 2010 14:31:30 +0000 (14:31 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 2 Feb 2010 14:31:30 +0000 (14:31 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/parted/parted-1.9.0/no_check.patch [moved from meta/packages/parted/parted-1.8.8/no_check.patch with 57% similarity]
meta/packages/parted/parted-1.9.0/syscalls.patch [moved from meta/packages/parted/parted-1.8.8/syscalls.patch with 76% similarity]
meta/packages/parted/parted_1.9.0.bb [moved from meta/packages/parted/parted_1.8.8.bb with 87% similarity]

similarity index 57%
rename from meta/packages/parted/parted-1.8.8/no_check.patch
rename to meta/packages/parted/parted-1.9.0/no_check.patch
index 22d364a0a7db14837b3b7f993880d532b36e6bb2..24a328ceea907f371a4b06f1202b02f33589559a 100644 (file)
@@ -3,15 +3,16 @@ it to be disabled.
 
 RP - 4/11/08
 
-Index: parted-1.8.8/configure.ac
+Index: parted-1.9.0/configure.ac
 ===================================================================
---- parted-1.8.8.orig/configure.ac     2008-11-04 15:18:17.000000000 +0000
-+++ parted-1.8.8/configure.ac  2008-11-04 15:18:31.000000000 +0000
-@@ -481,6 +481,6 @@
- AM_CONDITIONAL([COMPILE_FOR_S390], [test "$compile_for_s390" = "yes"])
+--- parted-1.9.0.orig/configure.ac     2009-07-23 18:52:08.000000000 +0100
++++ parted-1.9.0/configure.ac  2010-02-02 14:13:56.013905093 +0000
+@@ -477,7 +477,7 @@
+ AM_CONDITIONAL([BUILD_LINUX], [test "$OS" = linux])
  
  dnl check for "check", unit testing library/header
 -PKG_CHECK_MODULES([CHECK], [check >= 0.9.3], have_check=yes, have_check=no)
 +have_check=no
- if test "$have_scintilla" != "yes"; then
+ if test "$have_check" != "yes"; then
      AC_MSG_RESULT([Unable to locate check version 0.9.3 or higher: not building])
+ fi
similarity index 76%
rename from meta/packages/parted/parted-1.8.8/syscalls.patch
rename to meta/packages/parted/parted-1.9.0/syscalls.patch
index 042fc9769d56c44dfefa558ae888180703e8ef62..6be49968f3267ccb52c8c49af57863f0050c10bb 100644 (file)
@@ -2,20 +2,20 @@
  libparted/arch/linux.c |   13 +++++++++++++
  1 file changed, 13 insertions(+)
 
-Index: parted-1.8.8/libparted/arch/linux.c
+Index: parted-1.9.0/libparted/arch/linux.c
 ===================================================================
---- parted-1.8.8.orig/libparted/arch/linux.c   2007-08-09 20:47:57.000000000 +0200
-+++ parted-1.8.8/libparted/arch/linux.c        2008-10-06 13:49:17.000000000 +0200
-@@ -18,6 +18,8 @@
+--- parted-1.9.0.orig/libparted/arch/linux.c   2009-07-23 18:52:08.000000000 +0100
++++ parted-1.9.0/libparted/arch/linux.c        2010-02-02 14:14:16.523904768 +0000
+@@ -17,6 +17,8 @@
  
  #define PROC_DEVICES_BUFSIZ 16384
  
 +#include <linux/version.h>
 +
  #include <config.h>
+ #include <arch/linux.h>
  
- #include <parted/parted.h>
-@@ -1361,12 +1363,14 @@ linux_refresh_close (PedDevice* dev)
+@@ -1477,12 +1479,14 @@
  
  #if SIZEOF_OFF_T < 8
  
@@ -30,7 +30,7 @@ Index: parted-1.8.8/libparted/arch/linux.c
  
  loff_t
  llseek (unsigned int fd, loff_t offset, unsigned int whence)
-@@ -1374,11 +1378,20 @@ llseek (unsigned int fd, loff_t offset, 
+@@ -1490,11 +1494,20 @@
          loff_t result;
          int retval;
  
similarity index 87%
rename from meta/packages/parted/parted_1.8.8.bb
rename to meta/packages/parted/parted_1.9.0.bb
index 62054607605d831793c38f9b7b1f2dc248d31ec6..2a95b9ceaa83848277c297c3fc1360205418c3c6 100644 (file)
@@ -9,6 +9,6 @@ SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.gz \
            file://no_check.patch;patch=1 \
            file://syscalls.patch;patch=1 "
            
-EXTRA_OECONF = "--disable-Werror"
+EXTRA_OECONF = "--disable-Werror --disable-device-mapper"
 
 inherit autotools_stage pkgconfig gettext