]> code.ossystems Code Review - openembedded-core.git/commitdiff
valgrind: fix perl scripts
authorQing He <qing.he@intel.com>
Tue, 31 Aug 2010 14:51:58 +0000 (22:51 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 2 Sep 2010 08:50:49 +0000 (09:50 +0100)
svn version of valgrind uses #! @PERL@ for several perl
scripts. However, PERL in autoconf doesn't distinguish
host perl and target perl, causing STAGING_DIR_NATIVE be
written in the output scripts.

This causes unrunnable scripts, and fails FILERDEPENDS
mechanism (thus also do_rootfs_rpm).

Uses /usr/bin/perl instead to fix it.

Signed-off-by: Qing He <qing.he@intel.com>
meta/recipes-devtools/valgrind/valgrind/fixed-perl-path.patch [new file with mode: 0644]
meta/recipes-devtools/valgrind/valgrind_3.5.0.bb

diff --git a/meta/recipes-devtools/valgrind/valgrind/fixed-perl-path.patch b/meta/recipes-devtools/valgrind/valgrind/fixed-perl-path.patch
new file mode 100644 (file)
index 0000000..2a0440a
--- /dev/null
@@ -0,0 +1,51 @@
+this is a temporary patch to workaround cross compilation.
+otherwise @PERL@ will be replaced to perl-native binary,
+this creates unusable scripts and fails FILERDEPENDS mechanism
+(esp. rpm)
+
+a better fix would need:
+ 1. configure.ac should differentiate PERL and HOSTPERL
+ 2. optionally remove ${STAGING_DIR} in #! line before do_install
+
+8/31/2010 - created by Qing He <qing.he@intel.com>
+
+diff --git a/cachegrind/cg_annotate.in b/cachegrind/cg_annotate.in
+index 9dc9565..cc4ef05 100644
+--- a/cachegrind/cg_annotate.in
++++ b/cachegrind/cg_annotate.in
+@@ -1,4 +1,4 @@
+-#! @PERL@
++#! /usr/bin/perl
+ ##--------------------------------------------------------------------##
+ ##--- Cachegrind's annotator.                       cg_annotate.in ---##
+diff --git a/cachegrind/cg_diff.in b/cachegrind/cg_diff.in
+index 951066e..84c2dde 100644
+--- a/cachegrind/cg_diff.in
++++ b/cachegrind/cg_diff.in
+@@ -1,4 +1,4 @@
+-#! @PERL@
++#! /usr/bin/perl
+ ##--------------------------------------------------------------------##
+ ##--- Cachegrind's differencer.                         cg_diff.in ---##
+diff --git a/massif/ms_print.in b/massif/ms_print.in
+index e6ffdbf..fb45906 100755
+--- a/massif/ms_print.in
++++ b/massif/ms_print.in
+@@ -1,4 +1,4 @@
+-#! @PERL@
++#! /usr/bin/perl
+ ##--------------------------------------------------------------------##
+ ##--- Massif's results printer                         ms_print.in ---##
+diff --git a/perf/vg_perf.in b/perf/vg_perf.in
+index 2188a31..83ad024 100644
+--- a/perf/vg_perf.in
++++ b/perf/vg_perf.in
+@@ -1,4 +1,4 @@
+-#! @PERL@
++#! /usr/bin/perl
+ ##--------------------------------------------------------------------##
+ ##--- Valgrind performance testing script                  vg_perf ---##
+ ##--------------------------------------------------------------------##
index c1a73f878d5c093b4ef2b4840065e03cbe48a248..6eba66e5bddc2e08820c3ca119b6c6580e3d4396 100644 (file)
@@ -7,11 +7,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c46082167a314d785d012a244748d803 \
                     file://include/valgrind.h;beginline=1;endline=56;md5=13a71cedba99112334d8596162aec37e \
                     file://COPYING.DOCS;md5=8fdeb5abdb235a08e76835f8f3260215"
 DEPENDS = "virtual/libx11"
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "http://www.valgrind.org/downloads/valgrind-${PV}.tar.bz2 \
           file://valgrind_3.5.0-svn_r11264.patch.bz2 \
-          file://fix_issue_caused_by_ccache.patch " 
+          file://fix_issue_caused_by_ccache.patch \
+           file://fixed-perl-path.patch"
 
 COMPATIBLE_HOST = '(i.86|x86_64).*-linux'