]> code.ossystems Code Review - openembedded-core.git/commitdiff
psplash: create psplash tmpfs mount directory in psplash-init
authorStefan Agner <stefan.agner@toradex.com>
Sat, 20 Jul 2019 00:12:37 +0000 (02:12 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 20 Jul 2019 11:05:34 +0000 (12:05 +0100)
The psplash binary uses TMPDIR as directory to store the FIFO to
communicate with the psplash tools. This directory can be in any
location an init system determines to be suitable, psplash-init
uses /mnt/ for it. Rather than creating the mount directory in
the recipe, just create it in the init script itself. This allows
other init scripts to use a different location without having
an unnecessary .psplash directory in /mnt.

Signed-off-by: Stefan Agner <stefan.agner@toradex.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/psplash/files/psplash-init
meta/recipes-core/psplash/psplash_git.bb

index 0bce1de5366eed29f4b604d94770df68cd8c774f..fee23e681cfb34bee0684d35f16a6c2536bc5277 100755 (executable)
@@ -24,6 +24,7 @@ for x in $CMDLINE; do
 done
 
 export TMPDIR=/mnt/.psplash
+[ -d $TMPDIR ] || mkdir -p $TMPDIR
 mount tmpfs -t tmpfs $TMPDIR -o,size=40k
 
 rotation=0
index 3161a5e3f131481cf863cb5160f6d261e7aa7574..56734c158295bf0ab4b12777edd61baa94e093fc 100644 (file)
@@ -97,7 +97,6 @@ python do_compile () {
 }
 
 do_install_append() {
-       install -d ${D}/mnt/.psplash/
        install -d ${D}${sysconfdir}/init.d/
        install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash.sh
        install -d ${D}${bindir}
@@ -107,8 +106,6 @@ do_install_append() {
        rm -f ${D}${bindir}/psplash
 }
 
-FILES_${PN} += "/mnt/.psplash"
-
 INITSCRIPT_NAME = "psplash.sh"
 INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."