]> code.ossystems Code Review - openembedded-core.git/commitdiff
pixman: port to meson
authorRoss Burton <ross.burton@intel.com>
Thu, 19 Dec 2019 21:19:25 +0000 (21:19 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 28 Dec 2019 23:25:35 +0000 (23:25 +0000)
Disable libpng as that's only used in the tests and demos, that we don't build.

Drop iwmmxt disabling, we can add this back again if it fails.  Loongsoon
remains disabled as the build fails for edgerouter.

Drop the Neon/VFP2 mojo, this is a micro-optimisation. If the size improvement
is significant then this can be added back.

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-graphics/xorg-lib/pixman/0001-test-utils-Check-for-FE_INVALID-definition-before-us.patch
meta/recipes-graphics/xorg-lib/pixman_0.38.4.bb

index 782c1db0221d9f26efd9e4c688e82953f3fc168d..23cbf53a41c136088067dd961c56a65a958dbec2 100644 (file)
@@ -7,7 +7,7 @@ Some architectures e.g. nios2 do not support all exceptions
 
 Signed-off-by: Khem Raj <raj.khem@gmail.com>
 ---
-Upstream-Status: Submitted
+Upstream-Status: Submitted [https://gitlab.freedesktop.org/pixman/pixman/merge_requests/24]
 
  test/utils.c | 2 ++
  1 file changed, 2 insertions(+)
index 8588e5f16b009797f9e81c63c6e6c689f0caaabc..22e19ba069e2aef468d3617b947db4e248b24c24 100644 (file)
@@ -5,7 +5,7 @@ Porter/Duff model and implicit mask generation for geometric primitives \
 including trapezoids, triangles, and rectangles."
 HOMEPAGE = "http://www.pixman.org"
 SECTION = "x11/libs"
-DEPENDS = "zlib libpng"
+DEPENDS = "zlib"
 
 SRC_URI = "https://www.cairographics.org/releases/${BP}.tar.gz \
            file://0001-ARM-qemu-related-workarounds-in-cpu-features-detecti.patch \
@@ -25,15 +25,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=14096c769ae0cbb5fcb94ec468be11b3 \
                     file://pixman/pixman-arm-neon-asm.h;endline=24;md5=9a9cc1e51abbf1da58f4d9528ec9d49b \
                    "
 
-inherit autotools pkgconfig
+inherit meson pkgconfig
 
-IWMMXT = "--disable-arm-iwmmxt"
-LOONGSON_MMI = "--disable-loongson-mmi"
-# If target supports neon then disable the 'simd' (ie VFPv2) fallback, otherwise disable neon.
-NEON = "${@bb.utils.contains("TUNE_FEATURES", "neon", "--disable-arm-simd", "--disable-arm-neon" ,d)}"
-
-EXTRA_OECONF = "--disable-gtk ${IWMMXT} ${LOONGSON_MMI} ${NEON}"
-EXTRA_OECONF_class-native = "--disable-gtk"
-EXTRA_OECONF_class-nativesdk = "--disable-gtk"
+# These are for the tests and demos, which we don't install
+EXTRA_OEMESON = "-Dgtk=disabled -Dlibpng=disabled"
+# ld: pixman/libpixman-mmx.a(pixman-mmx.c.o):
+# linking mips:loongson_2f module with previous mips:isa64 modules 
+EXTRA_OEMESON += "-Dloongson-mmi=disabled"
 
 BBCLASSEXTEND = "native nativesdk"