]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-setuptools: Remove its provided by python-distribute
authorKhem Raj <raj.khem@gmail.com>
Thu, 30 Jan 2014 04:00:14 +0000 (20:00 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 2 Feb 2014 22:34:32 +0000 (22:34 +0000)
Use python-distribute-native in packagegroup-toolset-native

Also fixes warnings like

WARNING: The recipe python-setuptools is trying to install files into a
shared area when those files already exist. Those files and their
manifest location are:

/srv/ssd/sgw/builds/world/tmp/sysroots/qemux86-64/usr/lib/python2.7/site-packages/setuptools.pth
    Matched in manifest-qemux86-64-python-distribute

/srv/ssd/sgw/builds/world/tmp/sysroots/qemux86-64/usr/lib/python2.7/site-packages/site.pyc
    Matched in manifest-qemux86-64-python-distribute

/srv/ssd/sgw/builds/world/tmp/sysroots/qemux86-64/usr/lib/python2.7/site-packages/site.py
    Matched in manifest-qemux86-64-python-distribute

Conflicts:
meta/recipes-devtools/python/python-setuptools_1.4.bb

Signed-off-by: Khem Raj <raj.khem@gmail.com>
meta/recipes-devtools/python/python-distribute_0.6.32.bb
meta/recipes-devtools/python/python-setuptools_1.4.bb [deleted file]
meta/recipes-devtools/python/python3-distribute_0.6.32.bb
meta/recipes-gnome/packagegroups/packagegroup-toolset-native.bb

index 86ac8718a990bf3319a718cf22fa4e09119b2c5a..ddc8d00bcf07856582e9f7b45a66696696e01530 100644 (file)
@@ -12,6 +12,9 @@ DEPENDS_virtclass-native += "python-native"
 SRC_URI = " \
   http://pypi.python.org/packages/source/d/distribute/${SRCNAME}-${PV}.tar.gz \
 "
+SRC_URI[md5sum] = "acb7a2da81e3612bfb1608abe4f0e568"
+SRC_URI[sha256sum] = "8970cd1e148b5d1fea9430584aea66c45ea22d80e0933393ec49ebc388f718df"
+
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
 #  http://python-distribute.org/distribute_setup.py 
@@ -41,7 +44,6 @@ RDEPENDS_${PN} = "\
   python-compression \
 "
 
-SRC_URI[md5sum] = "acb7a2da81e3612bfb1608abe4f0e568"
-SRC_URI[sha256sum] = "8970cd1e148b5d1fea9430584aea66c45ea22d80e0933393ec49ebc388f718df"
+RPROVIDES_${PN} += "python-setuptools"
 
 BBCLASSEXTEND = "native"
diff --git a/meta/recipes-devtools/python/python-setuptools_1.4.bb b/meta/recipes-devtools/python/python-setuptools_1.4.bb
deleted file mode 100644 (file)
index 4138d28..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-SUMMARY = "Downloads, builds, installs, upgrades, and uninstalls Python packages"
-HOMEPAGE = "http://cheeseshop.python.org/pypi/setuptools"
-SECTION = "devel/python"
-LICENSE = "PSF"
-LIC_FILES_CHKSUM = "file://setup.py;beginline=107;endline=107;md5=8a314270dd7a8dbca741775415f1716e"
-
-SRCNAME = "setuptools"
-DEPENDS += "python"
-DEPENDS_class-native += "python-native"
-
-SRC_URI = "\
-  http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz\
-"
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-inherit distutils
-
-DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
-
-do_install_prepend() {
-    install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
-}
-
-RDEPENDS_${PN} = "\
-  python-stringold \
-  python-email \
-  python-shell \
-  python-distutils \
-  python-compression \
-"
-
-RDEPENDS_${PN}_class-native = "\
-  python-distutils \
-  python-compression \
-"
-
-SRC_URI[md5sum] = "5710464bc5a61d75f5087f15ce63cfe0"
-SRC_URI[sha256sum] = "75d288687066ed124311d6ca5f40ffa92a0e81adcd7fff318c6e84082713cf39"
-
-BBCLASSEXTEND = "native"
index 31fc56dfbc972210080311320ef526bb843a2933..d4f00cd797b7ef47fd8a91d8826c85b0db0ad6da 100644 (file)
@@ -12,6 +12,9 @@ DEPENDS_virtclass-native += "python3-native"
 SRC_URI = " \
   http://pypi.python.org/packages/source/d/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
 "
+SRC_URI[md5sum] = "acb7a2da81e3612bfb1608abe4f0e568"
+SRC_URI[sha256sum] = "8970cd1e148b5d1fea9430584aea66c45ea22d80e0933393ec49ebc388f718df"
+
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
 #  http://python-distribute.org/distribute_setup.py 
@@ -41,7 +44,6 @@ RDEPENDS_${PN} = "\
   python3-compression \
 "
 
-SRC_URI[md5sum] = "acb7a2da81e3612bfb1608abe4f0e568"
-SRC_URI[sha256sum] = "8970cd1e148b5d1fea9430584aea66c45ea22d80e0933393ec49ebc388f718df"
+RPROVIDES_${PN} += "python3-setuptools"
 
 BBCLASSEXTEND = "native"
index 07d4f1d7a900ea44b920f2f8278a3542e6b11919..f08cf1dfff06a85311962a7a43c4e939b939cbf2 100644 (file)
@@ -185,7 +185,7 @@ DEPENDS = "\
     python-pygobject-native \
     python-pyrex-native \
     python-scons-native \
-    python-setuptools-native \
+    python-distribute-native \
     python-smartpm-native \
     qemu-helper-native \
     qemu-native \