]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add a patch that avoids the entry getting focus and thus bringing up the
authorRobert Bradford <rob@openedhand.com>
Wed, 27 Feb 2008 15:39:07 +0000 (15:39 +0000)
committerRobert Bradford <rob@openedhand.com>
Wed, 27 Feb 2008 15:39:07 +0000 (15:39 +0000)
keyboard.

Remove old patch directory.

git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3872 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/pimlico/contacts-0.8/contacts-owl-window-menu.patch [deleted file]
meta/packages/pimlico/contacts_0.8.bb
meta/packages/pimlico/files/contacts-focus-avoidance.patch [new file with mode: 0644]

diff --git a/meta/packages/pimlico/contacts-0.8/contacts-owl-window-menu.patch b/meta/packages/pimlico/contacts-0.8/contacts-owl-window-menu.patch
deleted file mode 100644 (file)
index 1fbf1dc..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-Index: contacts-0.5/src/contacts-gtk.c
-===================================================================
---- contacts-0.5.orig/src/contacts-gtk.c       2007-04-20 14:35:36.000000000 +0100
-+++ contacts-0.5/src/contacts-gtk.c    2007-07-13 10:47:52.000000000 +0100
-@@ -178,8 +178,8 @@
-       vbox7 = gtk_vbox_new (FALSE, 0);
-       gtk_container_add (GTK_CONTAINER (main_window), vbox7);
--      main_menubar = gtk_menu_bar_new ();
--      gtk_box_pack_start (GTK_BOX (vbox7), main_menubar, FALSE, FALSE, 0);
-+      main_menubar = gtk_menu_new ();
-+      gtk_widget_show (main_menubar);
-       contacts_menu = gtk_menu_item_new_with_mnemonic (_("_Contacts"));
-       gtk_container_add (GTK_CONTAINER (main_menubar), contacts_menu);
-Index: contacts-0.5/src/Makefile.am
-===================================================================
---- contacts-0.5.orig/src/Makefile.am  2007-03-02 11:17:00.000000000 +0000
-+++ contacts-0.5/src/Makefile.am       2007-07-13 10:47:52.000000000 +0100
-@@ -28,7 +28,7 @@
-                     contacts-@FRONTEND@.c \
-                     contacts-@FRONTEND@.h
--contacts_LDADD   = $(CONTACTS_LIBS)
-+contacts_LDADD   = $(CONTACTS_LIBS) -lowl
- contacts_LDFLAGS = @CONTACTS_LIBS@
- MAINTAINERCLEANFILES = config.h.in Makefile.in
-Index: contacts-0.5/src/contacts-main.c
-===================================================================
---- contacts-0.5.orig/src/contacts-main.c      2007-04-20 15:46:23.000000000 +0100
-+++ contacts-0.5/src/contacts-main.c   2007-07-13 10:53:44.000000000 +0100
-@@ -27,6 +27,8 @@
- #include <libgnomevfs/gnome-vfs.h>
- #endif
-+#include "owlwindowmenu.h"
-+
- #include "bacon-message-connection.h"
- #include "contacts-defs.h"
- #include "contacts-utils.h"
-@@ -230,6 +232,10 @@
-       /* fix icon sizes to 16x16 for the moment... */
-       gtk_rc_parse_string ("gtk_icon_sizes=\"gtk-button=16,16:gtk-menu=16,16\"");
-+      gtk_widget_show_all (data->ui->main_menubar);
-+      owl_set_window_menu (GTK_WINDOW (data->ui->main_window),
-+                           GTK_MENU (data->ui->main_menubar));
-+
-       gtk_main ();
-       /* Unload the addressbook */
index d00752b9c44e5c99f7aea51c7b91c0ccba36e941..fac3dabb23cf6c49133e35755a15ce5d9986c03a 100644 (file)
@@ -6,4 +6,5 @@ SRC_URI = "http://pimlico-project.org/sources/${PN}/${PN}-${PV}.tar.gz \
           file://stock_contact.png \
           file://stock_person.png  \
           file://contacts-owl-window-menu.patch;patch=1 \
+           file://contacts-focus-avoidance.patch;patch=1 \
          "
diff --git a/meta/packages/pimlico/files/contacts-focus-avoidance.patch b/meta/packages/pimlico/files/contacts-focus-avoidance.patch
new file mode 100644 (file)
index 0000000..77aae90
--- /dev/null
@@ -0,0 +1,36 @@
+Index: src/contacts-gtk.c
+===================================================================
+--- src/contacts-gtk.c (revision 405)
++++ src/contacts-gtk.c (working copy)
+@@ -426,7 +426,6 @@
+       GTK_WIDGET_SET_FLAGS (edit_done_button, GTK_CAN_DEFAULT);
+-      gtk_widget_grab_focus (search_entry);
+       gtk_widget_grab_default (edit_button);
+       gtk_window_add_accel_group (GTK_WINDOW (main_window), accel_group);
+@@ -436,8 +435,9 @@
+       gtk_size_group_add_widget (size_group, summary_hbuttonbox);
+       g_object_unref (size_group);
++      /* Set it so no focus on the search box by default */
++      gtk_window_set_focus (GTK_WINDOW (main_window), NULL);
+-
+       /* connect signals */
+       g_signal_connect (G_OBJECT (main_window), "delete-event",
+                       G_CALLBACK (contacts_main_window_delete_event_cb), data);
+Index: src/contacts-edit-pane.c
+===================================================================
+--- src/contacts-edit-pane.c   (revision 405)
++++ src/contacts-edit-pane.c   (working copy)
+@@ -86,7 +86,7 @@
+       if (data->ui->edit_button)
+               gtk_window_set_default (window, data->ui->edit_button);
+       if ((widget = data->ui->search_entry) && GTK_WIDGET_VISIBLE (widget))
+-              gtk_window_set_focus (window, data->ui->search_entry);
++              gtk_window_set_focus (window, NULL);
+ }
+ static void