]> code.ossystems Code Review - openembedded-core.git/commitdiff
kern-tools: fix non-local patch/config location
authorBruce Ashfield <bruce.ashfield@windriver.com>
Fri, 12 Apr 2013 02:16:33 +0000 (02:16 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 12 Apr 2013 16:00:13 +0000 (17:00 +0100)
A regression was introduced when implementing the ability to restrict
configuration values via include directives. Only patch and config files that
were local to a feature directory could be found. While this doesn't impact
most users of the tools, it is an issue that needs to be fixed.

Additionally, the regex that detected flags passed to includes was not
specific enough, and unfortunately named feature files would match. This
resulted in features like standard-nocfg.scc inhibiting all configuration
items, even base configs.

This change also bumps the linux-yocto 3.4 and 3.8 PR values to ensure
that kernels will be rebuilt once this change is active.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
meta/recipes-kernel/linux/linux-yocto-rt_3.8.bb
meta/recipes-kernel/linux/linux-yocto-tiny_3.4.bb
meta/recipes-kernel/linux/linux-yocto-tiny_3.8.bb
meta/recipes-kernel/linux/linux-yocto_3.4.bb
meta/recipes-kernel/linux/linux-yocto_3.8.bb

index 9dcd896bcf0f2c788c296eaca5f5c053e2b45dc0..acef4b58892879615ab535675b8d909e8e4871c3 100644 (file)
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=d8d1d729a70c
 
 DEPENDS = "git-native guilt-native"
 
-SRCREV = "e3f59062bc594239856549e165c9e373cbbac1d6"
+SRCREV = "7a3170d96e142ce85a958f5b22e45f68f785f58d"
 PR = "r12"
 PV = "0.1+git${SRCPV}"
 
index 42339a1a1fd0559907dc0d8f8b4d4bb082a79b5d..88c05e264b752cec519b0d2a3f0a1bbacef33054 100644 (file)
@@ -12,7 +12,7 @@ SRCREV_machine ?= "7302a8f84da657ff72ca5a27b9212c9d3bee2fbf"
 SRCREV_machine_qemuppc ?= "494b16c51c6f6dc272eb820eaa57028ca8ee9da2"
 SRCREV_meta ?= "80b4b5110dca5184b57e85f1e775fb006a2e85ad"
 
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
index 3bf937f91b7aede27e91a24fb71e609e680be706..04642a4df0d66604b7cd2c9798f0c8e8d420b932 100644 (file)
@@ -12,7 +12,7 @@ SRCREV_machine ?= "0f7d294a9d07713059af345188f9cd4f549b4e77"
 SRCREV_machine_qemuppc ?= "82cdb00523b3f86219706d9f12dc80ff8d1c747a"
 SRCREV_meta ?= "27b63fdbd25ad1a37bacc05f49a205c150d21779"
 
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.8.git;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
index 4b6b4a015e4da3683093f4eb9479d1e4c0bb46da..54202b099a3eb8a6cbadfad6112f8a50cffbf441 100644 (file)
@@ -15,7 +15,7 @@ KMETA = "meta"
 SRCREV_machine ?= "c994390cfa28339cbc1ec3b56eeec83a5fa75bb7"
 SRCREV_meta ?= "80b4b5110dca5184b57e85f1e775fb006a2e85ad"
 
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
index 5a3331710af8ce44f04accda9edae1291e11cbd0..1fe4139e8f608ba1d27897a9926530e771df3e29 100644 (file)
@@ -15,7 +15,7 @@ KMETA = "meta"
 SRCREV_machine ?= "11998bd1f44b21cd0b8c0ca11cbd36865f14bfdc"
 SRCREV_meta ?= "27b63fdbd25ad1a37bacc05f49a205c150d21779"
 
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.8.git;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
index 604aa48f9089a9811680000f4f68b27123869965..b81b9ace7b655f4d06f5471b902f2482f79c7317 100644 (file)
@@ -15,7 +15,7 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;bareclone
 
 LINUX_VERSION ?= "3.4.36"
 
-PR = "${INC_PR}.3"
+PR = "${INC_PR}.4"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
 KMETA = "meta"
index c0906e52ab61fbdca0a63d332044cc15090368f6..91cc52debf4de5bc1e0367d23e5a1edaff8d80d7 100644 (file)
@@ -15,7 +15,7 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.8.git;protocol=git;bareclone
 
 LINUX_VERSION ?= "3.8.4"
 
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
 KMETA = "meta"