]> code.ossystems Code Review - openembedded-core.git/commitdiff
core-image-lsb-sdk/dev: Inherit the base image instead of duplicating
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 24 Jan 2013 05:56:10 +0000 (21:56 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 24 Jan 2013 20:07:58 +0000 (20:07 +0000)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/images/core-image-lsb-dev.bb
meta/recipes-extended/images/core-image-lsb-sdk.bb

index 013efb973d3c3172845182145fc7305edd5469f0..d2dc9e2b530aa161d9b78f580f3d1751e6f047fa 100644 (file)
@@ -1,13 +1,7 @@
+require core-image-lsb.bb
+
 DESCRIPTION = "Basic image without X support suitable for development work. It \
 can be used for customization and implementations that conform to Linux \
 Standard Base (LSB)."
 
-IMAGE_FEATURES += "splash dev-pkgs ssh-server-openssh"
-
-IMAGE_INSTALL = "\
-    ${CORE_IMAGE_BASE_INSTALL} \
-    packagegroup-core-basic \
-    packagegroup-core-lsb \
-    "
-
-inherit core-image
+IMAGE_FEATURES += "dev-pkgs"
index abddb767c6f759a6d44fd65896db2d780a7e49a1..da8c250d2e506951d9eb4a9cc30e601e13bccfe9 100644 (file)
@@ -1,16 +1,10 @@
+require core-image-lsb.bb
+
 DESCRIPTION = "Basic image without X support suitable for Linux Standard Base \
 (LSB) implementations. It includes the full meta-toolchain, plus development \
 headers and libraries to form a standalone SDK."
 
-IMAGE_FEATURES += "splash tools-sdk dev-pkgs ssh-server-openssh \
-       tools-debug tools-profile tools-testapps debug-tweaks"
-
+IMAGE_FEATURES += "tools-sdk dev-pkgs tools-debug tools-profile tools-testapps debug-tweaks"
 
-IMAGE_INSTALL = "\
-    ${CORE_IMAGE_BASE_INSTALL} \
-    packagegroup-core-basic \
-    packagegroup-core-lsb \
-    kernel-dev \
-    "
+IMAGE_INSTALL += "kernel-dev"
 
-inherit core-image