]> code.ossystems Code Review - openembedded-core.git/commitdiff
sysvinit: Remove cruft from rc we don't need
authorRichard Purdie <richard@openedhand.com>
Fri, 1 Aug 2008 11:34:31 +0000 (11:34 +0000)
committerRichard Purdie <richard@openedhand.com>
Fri, 1 Aug 2008 11:34:31 +0000 (11:34 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4998 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/sysvinit/sysvinit/rcS
meta/packages/sysvinit/sysvinit_2.86.bb

index 90af4149e4c86a138ad0374393774ebd3ed13b83..080b04f32fdc1b8e585082bffd0df66a5abe9a24 100755 (executable)
@@ -16,15 +16,6 @@ export PATH runlevel prevlevel
 #
 [ -d "/proc/1" ] || mount /proc
 
-#
-#      See if system needs to be setup. This is ONLY meant to
-#      be used for the initial setup after a fresh installation!
-#
-if [ -x /sbin/unconfigured.sh ]
-then
-  /sbin/unconfigured.sh
-fi
-
 #
 #      Source defaults.
 #
@@ -40,17 +31,4 @@ trap ":" INT QUIT TSTP
 #
 exec /etc/init.d/rc S
 
-#
-#      For compatibility, run the files in /etc/rc.boot too.
-#
-[ -d /etc/rc.boot ] && run-parts /etc/rc.boot
-
-#
-#      Finish setup if needed. The comment above about
-#      /sbin/unconfigured.sh applies here as well!
-#
-if [ -x /sbin/setup.sh ]
-then
-  /sbin/setup.sh
-fi
 
index a5e6237575ca7d258f9d41b8b643c490d3b93c26..e30970cb709cd5ca8eb69a8eaf34afd7d0a01af7 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "System-V like init."
 SECTION = "base"
 LICENSE = "GPL"
 HOMEPAGE = "http://freshmeat.net/projects/sysvinit/"
-PR = "r29"
+PR = "r30"
 
 # USE_VT and SERIAL_CONSOLE are generally defined by the MACHINE .conf.
 # Set PACKAGE_ARCH appropriately.