]> code.ossystems Code Review - openembedded-core.git/commitdiff
distcc: update to 3.3
authorHongxu Jia <hongxu.jia@windriver.com>
Fri, 11 May 2018 16:15:20 +0000 (00:15 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 29 May 2018 10:25:03 +0000 (11:25 +0100)
* update to version 3.3
* Remove 0001-zeroconf-Include-fcntl.h.patch since it's
  included in v3.3
* Add update-distcc-symlinks into FILES.

Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
* Correct upstream SRC_URI and SRCREV to v3.3
* Correct default to fix starting distccd service failed
  It caused by upstream commit:
  https://github.com/distcc/distcc/commit/920e8b922addea8c54e68cc29c1416753f532f78
  ...
  commit 920e8b922addea8c54e68cc29c1416753f532f78
  Author: Shawn Landden <slandden@gmail.com>
  Date:   Mon Feb 26 11:29:14 2018 -0800

      daemon: warn when masquerade is not setup
  ...
  Add option --make-me-a-botnet to disable the warning.

* Use localhost to replace 192.168.7.0/24 which is inappropriate for runqemu slirp.

[YOCTO #12741]

Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/distcc/distcc_3.3.bb [moved from meta/recipes-devtools/distcc/distcc_3.2.bb with 91% similarity]
meta/recipes-devtools/distcc/files/0001-zeroconf-Include-fcntl.h.patch [deleted file]
meta/recipes-devtools/distcc/files/default

similarity index 91%
rename from meta/recipes-devtools/distcc/distcc_3.2.bb
rename to meta/recipes-devtools/distcc/distcc_3.3.bb
index 66046480b90f9a562f52c479e3b19da7f3ccf42f..40648e2142fcf6d06618b24c905cad8559eb8acf 100644 (file)
@@ -14,14 +14,13 @@ PACKAGECONFIG[popt] = "--without-included-popt,--with-included-popt,popt"
 
 RRECOMMENDS_${PN} = "avahi-daemon"
 
-SRC_URI = "git://github.com/akuster/distcc.git;branch=${PV} \
+SRC_URI = "git://github.com/distcc/distcc.git \
            file://separatebuilddir.patch \
-           file://0001-zeroconf-Include-fcntl.h.patch \
            file://default \
            file://distccmon-gnome.desktop \
            file://distcc \
            file://distcc.service"
-SRCREV = "d8b18df3e9dcbe4f092bed565835d3975e99432c"
+SRCREV = "002e68b766ccd7ad05551e67d162b71a7a773d0d"
 S = "${WORKDIR}/git"
 
 inherit autotools pkgconfig update-rc.d useradd systemd
@@ -61,9 +60,10 @@ PACKAGES += "distcc-distmon-gnome"
 
 FILES_${PN} = " ${sysconfdir} \
                ${bindir}/distcc \
-    ${bindir}/lsdistcc \
+               ${bindir}/lsdistcc \
                ${bindir}/distccd \
                ${bindir}/distccmon-text \
+               ${sbindir}/update-distcc-symlinks \
                ${systemd_unitdir}/system/distcc.service"
 FILES_distcc-distmon-gnome = "  ${bindir}/distccmon-gnome \
                                ${datadir}/distcc"
diff --git a/meta/recipes-devtools/distcc/files/0001-zeroconf-Include-fcntl.h.patch b/meta/recipes-devtools/distcc/files/0001-zeroconf-Include-fcntl.h.patch
deleted file mode 100644 (file)
index b17ec9c..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-From 8331fc4759d809512f404e7a27f817ad6d616450 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Mon, 13 Apr 2015 18:00:33 -0700
-Subject: [PATCH] zeroconf: Include fcntl.h
-
-We need it for getting deinitions for O_* e.g. O_CREAT
-
-Upstream-Status: Pending
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/zeroconf.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/zeroconf.c b/src/zeroconf.c
-index 414ddc4..31bd33f 100644
---- a/src/zeroconf.c
-+++ b/src/zeroconf.c
-@@ -33,6 +33,7 @@
- #include <unistd.h>
- #include <stdlib.h>
- #include <limits.h>
-+#include <fcntl.h>
- #include <avahi-common/domain.h>
- #include <avahi-common/error.h>
--- 
-2.1.4
-
index 63c4159b9d1b8a28e191b2e85b59ed0d1ef0604c..e5ca68b85613c62f71458605e207329cb807979b 100644 (file)
@@ -16,9 +16,9 @@ STARTDISTCC="true"
 #
 # ALLOWEDNETS="127.0.0.1"
 
-ALLOWEDNETS="192.168.7.0/24"
+ALLOWEDNETS="127.0.0.1"
 
 #
 # OPTIONS is used for the systemd service file
 #
-OPTIONS="--allow 192.168.7.0/24"
+OPTIONS="--allow 127.0.0.1 --make-me-a-botnet"