]> code.ossystems Code Review - openembedded-core.git/commitdiff
libzypp: Fix build with uclibc
authorKhem Raj <raj.khem@gmail.com>
Mon, 4 Jun 2012 22:09:10 +0000 (15:09 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Jun 2012 12:16:36 +0000 (13:16 +0100)
cstdio is included indrectly with eglibc based systems
but not with uclibc based systems and use of functions
like ::eof are then reported as warnings. Therefore
we include cstdio explicitly.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
meta/recipes-extended/libzypp/libzypp_git.bb

index 471ee1d6903db1a8514e6e6dae8d6cebd0501237..3a323e7e15c581a28089826e2fde1ba87636960b 100644 (file)
@@ -51,6 +51,8 @@ FILES_${PN}-pkgmgt = "${bindir}/package-manager \
 EXTRA_OECMAKE += " -DLIB=${@os.path.basename('${libdir}')}"
 OECMAKE_CXX_LINK_FLAGS_libc-uclibc += "-pthread"
 
+LDFLAGS += "-lpthread"
+
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 AVOID_CONSTRUCTOR = ""