]> code.ossystems Code Review - openembedded-core.git/commitdiff
socat: turn hard readline dependency into an option
authorAlexander Kanavin <alex.kanavin@gmail.com>
Thu, 10 Oct 2019 11:18:39 +0000 (13:18 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 10 Oct 2019 15:55:54 +0000 (16:55 +0100)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/socat/socat_1.7.3.3.bb

index 067f7c644437c5271d895e140511793218973553..1dbbe5cd558c8545a3d681b3e5ae48ada9dfef2b 100644 (file)
@@ -5,7 +5,7 @@ HOMEPAGE = "http://www.dest-unreach.org/socat/"
 
 SECTION = "console/network"
 
-DEPENDS = "openssl readline"
+DEPENDS = "openssl"
 
 LICENSE = "GPL-2.0-with-OpenSSL-exception"
 LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
@@ -39,9 +39,10 @@ TERMBITS_SHIFTS_powerpc64 = "sc_cv_sys_crdly_shift=12 \
                              sc_cv_sys_tabdly_shift=10 \
                              sc_cv_sys_csize_shift=8"
 
-PACKAGECONFIG_class-target ??= "tcp-wrappers"
-PACKAGECONFIG ??= ""
+PACKAGECONFIG_class-target ??= "tcp-wrappers readline"
+PACKAGECONFIG ??= "readline"
 PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
+PACKAGECONFIG[readline] = "--enable-readline,--disable-readline,readline"
 
 do_install_prepend () {
     mkdir -p ${D}${bindir}