]> code.ossystems Code Review - openembedded-core.git/commitdiff
eudev: Add PACKAGE_WRITE_DEPS for postinstall
authorJussi Kukkonen <jussi.kukkonen@intel.com>
Thu, 19 Jan 2017 08:07:44 +0000 (10:07 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 19 Jan 2017 22:51:08 +0000 (22:51 +0000)
Qemu is used to run udevadm in postinstall.

Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
meta/recipes-core/udev/eudev_3.2.bb

index 211252cebc562fd865a0b30260da73d0ef6f7c43..385ee7acc2baa38cdb262e39c12a9919fcfa8ded 100644 (file)
@@ -87,6 +87,7 @@ python () {
         raise bb.parse.SkipPackage("'systemd' in DISTRO_FEATURES")
 }
 
+PACKAGE_WRITE_DEPS += "qemu-native"
 pkg_postinst_eudev-hwdb () {
     if test -n "$D"; then
         ${@qemu_run_binary(d, '$D', '${bindir}/udevadm')} hwdb --update --root $D