]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add libfakekey for matchbox packages
authorRichard Purdie <richard@openedhand.com>
Wed, 28 Sep 2005 22:52:37 +0000 (22:52 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 28 Sep 2005 22:52:37 +0000 (22:52 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky@55 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/libfakekey/libfakekey_svn.bb [new file with mode: 0644]

diff --git a/openembedded/packages/libfakekey/libfakekey_svn.bb b/openembedded/packages/libfakekey/libfakekey_svn.bb
new file mode 100644 (file)
index 0000000..172fecc
--- /dev/null
@@ -0,0 +1,23 @@
+DESCRIPTION = "Matchbox keyboard"
+LICENSE = "GPL"
+DEPENDS = "xtst"
+SECTION = "x11/wm"
+PR="r1"
+PV = "0.0+svn${CVSDATE}"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http"
+
+S = "${WORKDIR}/${PN}"
+
+inherit autotools pkgconfig gettext
+
+FILES_${PN} = "${libdir} \
+              ${datadir}/applications \
+              ${datadir}/pixmaps"
+
+do_stage () {
+          install -d ${STAGING_INCDIR}/fakekey 
+           install -m 0644 ${S}/fakekey/fakekey.h ${STAGING_INCDIR}/fakekey
+           oe_libinstall -so -C src libfakekey ${STAGING_LIBDIR}               
+}
+