]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-smartpm: Fix channel command --remove-all option (again)
authorKlauer, Daniel <Daniel.Klauer@gin.de>
Tue, 17 May 2016 12:55:39 +0000 (12:55 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 29 Jun 2016 18:34:42 +0000 (19:34 +0100)
SmartPM's --remove-all option was unusable, because the fix from
commit 03266e89a6 was lost in commit 5fc580fc44. Thus, add a new
patch to fix --remove-all.

It seems like the previous fix was lost by mistake:
Upstream merged the *old* version of the patch (smartpm 406541f569),
and when SmartPM in oe-core was upgraded to the new upstream release,
the --remove-all fix from the *new* patch was not carried over.

(From OE-Core rev: ba2adda60dd34b6a8feba413e3207dd8e4580294)

Signed-off-by: Daniel Klauer <daniel.klauer@gin.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python-smartpm/smart-channel-remove-all.patch [new file with mode: 0644]
meta/recipes-devtools/python/python-smartpm_git.bb

diff --git a/meta/recipes-devtools/python/python-smartpm/smart-channel-remove-all.patch b/meta/recipes-devtools/python/python-smartpm/smart-channel-remove-all.patch
new file mode 100644 (file)
index 0000000..da23e7c
--- /dev/null
@@ -0,0 +1,33 @@
+From 6d2363a705697f615d9e5af5d6703b291e618b46 Mon Sep 17 00:00:00 2001
+From: Daniel Klauer <daniel.klauer@gin.de>
+Date: Thu, 12 May 2016 17:55:01 +0200
+Subject: [PATCH] Fix channel command --remove-all option parsing
+
+Option.take_action() stores a list of options given for validation later.
+It strips leading dashes and turns remaining dashes into underscores.
+This list is what ensure_action() will compare its arguments against,
+thus we must use underscores here.
+
+Upstream-Status: Pending
+
+Signed-off-by: Daniel Klauer <daniel.klauer@gin.de>
+---
+ smart/commands/channel.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/smart/commands/channel.py b/smart/commands/channel.py
+index 108f3f1..6234f69 100644
+--- a/smart/commands/channel.py
++++ b/smart/commands/channel.py
+@@ -164,7 +164,7 @@ def main(ctrl, opts):
+     opts.check_args_of_option("edit", 0)
+     opts.check_args_of_option("enable", -1)
+     opts.check_args_of_option("disable", -1)
+-    opts.ensure_action("channel", ["add", "set", "remove", "remove-all",
++    opts.ensure_action("channel", ["add", "set", "remove", "remove_all",
+                        "list", "show", "yaml", "enable", "disable"])
+     opts.check_remaining_args()
+-- 
+1.9.1
+
index d9a908db2e2181efccce1559042cf7ef12bbc156..f030b3eb37c43c7cd42b5ae34c21107165e6713d 100644 (file)
@@ -23,6 +23,7 @@ SRC_URI = "\
           file://smart-already-installed-message.patch \
           file://smart-set-noprogress-for-pycurl.patch \
           file://smart-cache.py-getPackages-matches-name-version.patch \
+          file://smart-channel-remove-all.patch \
          "
 
 SRCREV = "407a7eca766431257dcd1da15175cc36a1bb22d0"