]> code.ossystems Code Review - openembedded-core.git/commitdiff
libnewt: fix parallel-make issue
authorDexuan Cui <dexuan.cui@intel.com>
Fri, 15 Apr 2011 08:40:47 +0000 (16:40 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Apr 2011 04:43:23 +0000 (05:43 +0100)
Add patch to remove hardcoded /usr/include/slang

Fixes [YOCTO #947]

Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/newt/files/fix_SHAREDDIR.patch [new file with mode: 0644]
meta/recipes-extended/newt/files/include-without-python.patch
meta/recipes-extended/newt/files/remove_slang_include.patch [new file with mode: 0644]
meta/recipes-extended/newt/libnewt_0.52.12.bb

diff --git a/meta/recipes-extended/newt/files/fix_SHAREDDIR.patch b/meta/recipes-extended/newt/files/fix_SHAREDDIR.patch
new file mode 100644 (file)
index 0000000..7795260
--- /dev/null
@@ -0,0 +1,29 @@
+Upstream-Status: Pending
+
+Author: dexuan.cui@intel.com
+Date: Fri Apr 15 16:17:39 CST 2011
+
+The patch fixes a parallel-make issue: when generating $(SHAREDDIR)/%.o, we should
+ensure the directory ${SHAREDDIR} exists.
+
+We need to push the patch to upstream.
+
+Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -114,12 +114,12 @@
+ sharedlib: $(LIBNEWTSH)
+-$(LIBNEWTSH): $(SHAREDDIR) $(SHAREDOBJS)
++$(LIBNEWTSH): $(SHAREDOBJS)
+       $(CC) -shared -o $(LIBNEWTSH) $(SHLIBFLAGS) $(SHAREDOBJS) $(LDFLAGS) $(LIBS)
+       ln -fs $(LIBNEWTSONAME) libnewt.so
+       ln -fs $(LIBNEWTSH) $(LIBNEWTSONAME)
+-$(SHAREDDIR)/%.o : %.c
++$(SHAREDDIR)/%.o : %.c $(SHAREDDIR)
+       $(CC) $(SHCFLAGS) -c $(CFLAGS) $(CPPFLAGS) -o $@ $<
+ install: $(LIBNEWT) install-sh whiptail
index 277ee3324d0286b237c7a24c96f7c3838559c35a..263e9de039d259d0c4a166eb781e54d293c8c70b 100644 (file)
@@ -1,3 +1,5 @@
+Upstream-Status: Pending
+
 From 3d13bbbb769050fac4cc6c904c174edc27e4f03d Mon Sep 17 00:00:00 2001
 From: Otavio Salvador <otavio@ossystems.com.br>
 Date: Thu, 20 Jan 2011 14:14:51 -0200
diff --git a/meta/recipes-extended/newt/files/remove_slang_include.patch b/meta/recipes-extended/newt/files/remove_slang_include.patch
new file mode 100644 (file)
index 0000000..dbdeef0
--- /dev/null
@@ -0,0 +1,13 @@
+Index: git/Makefile.in
+===================================================================
+--- git.orig/Makefile.in
++++ git/Makefile.in
+@@ -5,7 +5,7 @@ CC = @CC@
+ CPP = @CPP@
+ CFLAGS = @CFLAGS@
+ LDFLAGS = @LDFLAGS@
+-CPPFLAGS = -D_GNU_SOURCE -I/usr/include/slang @CPPFLAGS@ 
++CPPFLAGS = -D_GNU_SOURCE @CPPFLAGS@ 
+ GNU_LD = @GNU_LD@
+ VERSION = @VERSION@
index eefd6bdfd91dde9916662c80cd1607a8bc991b5f..e2ad55964db647739e63a2436c8f552662bed435 100644 (file)
@@ -17,11 +17,15 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
 # slang needs to be >= 2.2
 DEPENDS = "slang popt"
 
-PR = "r0"
+PR = "r2"
 
 SRCREV = "c3c7be75f6ef1adfc2be5f99c1e8ef3f0ab58c38"
+
 SRC_URI = "git://git.fedorahosted.org/git/newt;protocol=git \
-           file://include-without-python.patch"
+           file://include-without-python.patch \
+           file://remove_slang_include.patch \
+           file://fix_SHAREDDIR.patch"
+
 S = "${WORKDIR}/git"
 
 EXTRA_OECONF = "--without-python --without-tcl"